Opened 6 years ago

Closed 6 years ago

#37455 closed defect (fixed)

fdupes is not UsingTheRightCompiler

Reported by: dave@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: haspatch Cc: ryandesign (Ryan Schmidt)
Port: fdupes

Description

see attached log file

cube:~ dave% sudo port install fdupes--->  Building fdupes
Error: org.macports.build for port fdupes returned: command execution failed
Please see the log file for port fdupes for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_fdupes/fdupes/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port fdupes failed

Attachments (1)

main.log (3.7 KB) - added by dave@… 6 years ago.
build log

Download all attachments as: .zip

Change History (5)

Changed 6 years ago by dave@…

Attachment: main.log added

build log

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: nomaintainer@… removed
Summary: fdupes build brokenfdupes is not UsingTheRightCompiler

The log says:

:info:build gcc: Error: You should be using ${configure.cc}
:info:build See https://trac.macports.org/wiki/UsingTheRightCompiler
:info:build To suppress this error for the purposes of getting things done,
:info:build edit the binpath variable in /opt/local/etc/macports/macports.conf.

comment:2 Changed 6 years ago by dave@…

It took me a while to realize that you were only quoting the log in order to justify your change to the Summary.

To make it work you can add this to the post-patch block:

    reinplace "s|gcc|${configure.cc}|g" ${worksrcpath}/Makefile

comment:3 in reply to:  2 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: haspatch added

Replying to dave@…:

It took me a while to realize that you were only quoting the log in order to justify your change to the Summary.

Yes; the summary should describe the actual problem; "build broken" is very generic and not descriptive. I also wanted to point out that the error message was self-imposed; you have evidently followed the steps in UsingTheRightCompiler, which are designed to provoke this error message; users who have not done so would not have been affected.

To make it work you can add this to the post-patch block:

    reinplace "s|gcc|${configure.cc}|g" ${worksrcpath}/Makefile

Thanks, I'll look into it.

comment:4 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Such a reinplace would use the right compiler, but would not fix the other problem that ports that aren't using the right compiler usually suffer from as well, which is using the right -arch flags. The problem is the Makefile is poorly-written and does not expose the usual variables one uses to influence these things. Fortunately a newer development version is available, and its Makefile is a bit improved, so I back-ported some of those changes in r100902.

Note: See TracTickets for help on using tickets.