Opened 8 years ago

Closed 8 years ago

#37518 closed defect (duplicate)

xorg-server-devel @1.13.99.901: Build of X11.bin fails on PPC Tiger, Mac OS X 10.4.11, due to multiple definitions of many symbols

Reported by: ballapete (Peter Dyballa) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: xorg-server-devel

Description

The built fails because dozens of symbols are defined in more than one library:

/bin/sh ../../../libtool  --tag=CC   --mode=link /usr/bin/gcc-4.0 -std=gnu99 -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wmissing-declarations -Wformat=2 -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wbad-function-cast -Wold-style-definition -Wdeclaration-after-statement -Wunused -Wuninitialized -Wshadow -Wcast-qual -Wmissing-noreturn -Wmissing-format-attribute -Wredundant-decls -fno-strict-aliasing -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I/opt/local/include -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2   -I../../../include -I../../../include -I../../../Xext  -I../../../damageext -I../../../xfixes -I../../../Xi -I../../../mi -I../../../miext/sync -I../../../miext/shadow  -I../../../miext/damage -I../../../render -I../../../randr -I../../../fb -I../../../dbe -pipe -O2 -arch ppc -DROOTLESS_WORKAROUND -DROOTLESS_SAFEALPHA -DNO_ALLOCA -lXplugin -XCClinker -Objc -Wl,-u,_miDCInitialize -Wl,-framework,Carbon -Wl,-framework,Cocoa -Wl,-framework,CoreAudio -Wl,-framework,IOKit -Wl,-framework,OpenGL  -L/opt/local/lib -arch ppc -o X11.bin bundle-main.o strndup.o mach_startupServer.o mach_startupUser.o ../../../hw/xquartz/libXquartz.la ../../../hw/xquartz/xpr/libXquartzXpr.la ../../../dix/dixfonts.lo ../../../miext/rootless/librootless.la ../../../hw/xquartz/pbproxy/libxpbproxy.la ../../../dix/libmain.la ../../../fb/libfb.la ../../../xfixes/libxfixes.la ../../../Xext/libXext.la ../../../dbe/libdbe.la ../../../record/librecord.la ../../../randr/librandr.la ../../../render/librender.la ../../../damageext/libdamageext.la ../../../miext/sync/libsync.la ../../../miext/damage/libdamage.la ../../../miext/shadow/libshadow.la ../../../Xi/libXi.la ../../../xkb/libxkb.la ../../../xkb/libxkbstubs.la  ../../../dix/libdix.la ../../../mi/libmi.la ../../../os/libos.la ../../../hw/xquartz/GL/libCGLCore.la ../../../glx/libglx.la ../../../record/librecord.la -L/opt/local/lib -lpixman-1 -lXfont -lXau -lXdmcp    -lm  -lm 
libtool: link: /usr/bin/gcc-4.0 -std=gnu99 -DHAVE_DIX_CONFIG_H -Wall -Wpointer-arith -Wmissing-declarations -Wformat=2 -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Wbad-function-cast -Wold-style-definition -Wdeclaration-after-statement -Wunused -Wuninitialized -Wshadow -Wcast-qual -Wmissing-noreturn -Wmissing-format-attribute -Wredundant-decls -fno-strict-aliasing -fno-strict-aliasing -D_BSD_SOURCE -DHAS_FCHOWN -DHAS_STICKY_DIR_BIT -I/opt/local/include -I/opt/local/include/pixman-1 -I/opt/local/include/freetype2 -I../../../include -I../../../include -I../../../Xext -I../../../damageext -I../../../xfixes -I../../../Xi -I../../../mi -I../../../miext/sync -I../../../miext/shadow -I../../../miext/damage -I../../../render -I../../../randr -I../../../fb -I../../../dbe -pipe -O2 -arch ppc -DROOTLESS_WORKAROUND -DROOTLESS_SAFEALPHA -DNO_ALLOCA -Objc -Wl,-u -Wl,_miDCInitialize -Wl,-framework -Wl,Carbon -Wl,-framework -Wl,Cocoa -Wl,-framework -Wl,CoreAudio -Wl,-framework -Wl,IOKit -Wl,-framework -Wl,OpenGL -arch ppc -o X11.bin bundle-main.o strndup.o mach_startupServer.o mach_startupUser.o ../../../dix/.libs/dixfonts.o  -lXplugin -L/opt/local/lib ../../../hw/xquartz/.libs/libXquartz.a ../../../hw/xquartz/xpr/.libs/libXquartzXpr.a ../../../miext/rootless/.libs/librootless.a ../../../hw/xquartz/pbproxy/.libs/libxpbproxy.a /opt/local/lib/libAppleWM.dylib /opt/local/lib/libXext.dylib /opt/local/lib/libXfixes.dylib /opt/local/lib/libX11.dylib /opt/local/lib/libxcb.dylib ../../../dix/.libs/libmain.a ../../../fb/.libs/libfb.a ../../../xfixes/.libs/libxfixes.a ../../../Xext/.libs/libXext.a ../../../dbe/.libs/libdbe.a ../../../randr/.libs/librandr.a ../../../render/.libs/librender.a ../../../damageext/.libs/libdamageext.a ../../../miext/sync/.libs/libsync.a ../../../miext/damage/.libs/libdamage.a ../../../miext/shadow/.libs/libshadow.a ../../../Xi/.libs/libXi.a ../../../xkb/.libs/libxkb.a ../../../xkb/.libs/libxkbstubs.a ../../../dix/.libs/libdix.a ../../../mi/.libs/libmi.a ../../../os/.libs/libos.a ../../../hw/xquartz/GL/.libs/libCGLCore.a ../../../glx/.libs/libglx.a ../../../record/.libs/librecord.a /opt/local/lib/libpixman-1.dylib -lpthread /opt/local/lib/libXfont.dylib /opt/local/lib/libfreetype.dylib -lbz2 /opt/local/lib/libfontenc.dylib -lz /opt/local/lib/libXau.dylib /opt/local/lib/libXdmcp.dylib -lm -framework ApplicationServices
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _DeleteFontClientID
../../../dix/.libs/dixfonts.o definition of _DeleteFontClientID in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _DeleteFontClientID
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _ErrorF
../../../os/.libs/libos.a(log.o) definition of _ErrorF in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _ErrorF
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _FatalError
../../../os/.libs/libos.a(log.o) definition of _FatalError in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _FatalError
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _GetClientResolutions
../../../dix/.libs/dixfonts.o definition of _GetClientResolutions in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _GetClientResolutions
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _GetDefaultPointSize
../../../dix/.libs/dixfonts.o definition of _GetDefaultPointSize in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _GetDefaultPointSize
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _GetNewFontClientID
../../../dix/.libs/dixfonts.o definition of _GetNewFontClientID in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _GetNewFontClientID
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _GetTimeInMillis
../../../os/.libs/libos.a(utils.o) definition of _GetTimeInMillis in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _GetTimeInMillis
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _RegisterFPEFunctions
../../../dix/.libs/dixfonts.o definition of _RegisterFPEFunctions in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _RegisterFPEFunctions
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _StoreFontClientFont
../../../dix/.libs/dixfonts.o definition of _StoreFontClientFont in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _StoreFontClientFont
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _client_auth_generation
../../../dix/.libs/dixfonts.o definition of _client_auth_generation in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _client_auth_generation
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _find_old_font
../../../dix/.libs/dixfonts.o definition of _find_old_font in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _find_old_font
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _init_fs_handlers
../../../dix/.libs/dixfonts.o definition of _init_fs_handlers in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _init_fs_handlers
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _remove_fs_handlers
../../../dix/.libs/dixfonts.o definition of _remove_fs_handlers in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _remove_fs_handlers
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: warning multiple definitions of symbol _set_font_authorizations
../../../os/.libs/libos.a(utils.o) definition of _set_font_authorizations in section (__TEXT,__text)
/opt/local/lib/libXfont.dylib(single module) definition of _set_font_authorizations
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: multiple definitions of symbol _ClientSignal
/opt/local/lib/libXfont.dylib(single module) definition of _ClientSignal
../../../dix/.libs/libdix.a(dixutils.o) definition of _ClientSignal in section (__TEXT,__text)
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: multiple definitions of symbol _serverClient
/opt/local/lib/libXfont.dylib(single module) definition of _serverClient
../../../dix/.libs/libdix.a(globals.o) definition of _serverClient in section (__DATA,__common)
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: multiple definitions of symbol _serverGeneration
/opt/local/lib/libXfont.dylib(single module) definition of _serverGeneration
../../../dix/.libs/libdix.a(globals.o) definition of _serverGeneration in section (__DATA,__data)
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: multiple definitions of symbol _MakeAtom
/opt/local/lib/libXfont.dylib(single module) definition of _MakeAtom
../../../dix/.libs/libdix.a(atom.o) definition of _MakeAtom in section (__TEXT,__text)
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: multiple definitions of symbol _NameForAtom
/opt/local/lib/libXfont.dylib(single module) definition of _NameForAtom
../../../dix/.libs/libdix.a(atom.o) definition of _NameForAtom in section (__TEXT,__text)
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: multiple definitions of symbol _ValidAtom
/opt/local/lib/libXfont.dylib(single module) definition of _ValidAtom
../../../dix/.libs/libdix.a(atom.o) definition of _ValidAtom in section (__TEXT,__text)
/usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/ld: multiple definitions of symbol _XkbFreeGeomOverlayKeys
/opt/local/lib/libX11.dylib(single module) definition of _XkbFreeGeomOverlayKeys
../../../xkb/.libs/libxkb.a(XKBGAlloc.o) definition of _XkbFreeGeomOverlayKeys in section (__TEXT,__text)
collect2: ld returned 1 exit status
make[4]: *** [X11.bin] Error 1
make[4]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_x11_xorg-server-devel/xorg-server-devel/work/xorg-server-devel-1.13.99.901/hw/xquartz/mach-startup'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_x11_xorg-server-devel/xorg-server-devel/work/xorg-server-devel-1.13.99.901/hw/xquartz/mach-startup'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_x11_xorg-server-devel/xorg-server-devel/work/xorg-server-devel-1.13.99.901/hw/xquartz'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_x11_xorg-server-devel/xorg-server-devel/work/xorg-server-devel-1.13.99.901/hw'
make: *** [all-recursive] Error 1
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_x11_xorg-server-devel/xorg-server-devel/work/xorg-server-devel-1.13.99.901'
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_lil.fr.rsync.macports.org_release_tarballs_ports_x11_xorg-server-devel/xorg-server-devel/work/xorg-server-devel-1.13.99.901" && /usr/bin/make -w all V=1 
Exit code: 2

Attachments (1)

main.log (4.0 MB) - added by ballapete (Peter Dyballa) 8 years ago.
main.log

Change History (2)

Changed 8 years ago by ballapete (Peter Dyballa)

Attachment: main.log added

main.log

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Summary: Build of X11.bin in xorg-server-devel-1.13.99.901 fails on PPC Tiger, Mac OS X 10.4.11, due to multiple definitions of many symbolsxorg-server-devel @1.13.99.901: Build of X11.bin fails on PPC Tiger, Mac OS X 10.4.11, due to multiple definitions of many symbols

I think we can call this a duplicate of #36055.

Note: See TracTickets for help on using tickets.