Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#37526 closed defect (duplicate)

apple-gcc40: rev-upgrade says: crt3.o: Premature end of data, possibly corrupt file

Reported by: aroopsircar@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: rev-upgrade Cc: neverpanic (Clemens Lang), ryandesign (Ryan Schmidt), cooljeanius (Eric Gallager)
Port: apple-gcc40

Description (last modified by ryandesign (Ryan Schmidt))

Hello,

I am trying to install the gcc48 port but it keeps returning an error. To that end I have tried to remove both gcc48 and apple-gcc40 and followed it with clean and have reinstalled both, but keep getting the same error:

Mac OSX: Version 10.6.8
Xcode: 3.2.6 (1761)
Processor: 2.66 GHz Intel Core i7
Memory: 8 GB 1067 MHz DDR3

[aroop@woof lib]$  sudo port clean gcc48
--->  Cleaning gcc48
[aroop@woof lib]$ sudo port install gcc48
--->  Computing dependencies for gcc48
--->  Cleaning gcc48
--->  Scanning binaries for linking errors: 98.0%
Warning: Error parsing file /opt/local/lib/apple-gcc40/lib/gcc/i686-apple-darwin10.8.0/4.0.1/kext/crt3.o: Premature end of data, possibly corrupt file
--->  Scanning binaries for linking errors: 98.2%
Warning: Error parsing file /opt/local/lib/apple-gcc40/lib/gcc/i686-apple-darwin10.8.0/4.0.1/static/crt3.o: Premature end of data, possibly corrupt file
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.

Also if it does build successfully, where will I find (location) the gcc executable?

Thank you for your help,
Aroop

Change History (3)

comment:1 in reply to:  description Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: cal@… ryandesign@… added
Description: modified (diff)
Keywords: rev-upgrade added; gcc g++ removed
Port: apple-gcc40 added; gcc48 removed
Summary: gcc48 @ 4.8-20121230_0 build failureapple-gcc40: rev-upgrade says: crt3.o: Premature end of data, possibly corrupt file

Replying to aroopsircar@…:

I am trying to install the gcc48 port but it keeps returning an error.

Warning: Error parsing file /opt/local/lib/apple-gcc40/lib/gcc/i686-apple-darwin10.8.0/4.0.1/kext/crt3.o: Premature end of data, possibly corrupt file

It's just a warning actually, not an error. This output is part of the "rev-upgrade" feature of MacPorts, which, after you install or upgrade any port, checks every installed port to see if there are any linking errors. It's trying to locate and check OS X Mach-O binaries and libraries. In this case, rev-upgrade has identified this particular file crt3.o as a Mach-O file, but I'm guessing that in fact it isn't, and so it prints a warning saying it might be corrupt. That's probably fine and normal for this file. It might be nice to enhance the rev-upgrade feature so that it recognizes this type of file and skips over it instead of reporting it as corrupt, but I don't know what criteria would be used to differentiate this file from the Mach-O files that it does need to check. I'm Cc'ing Clemens who designed the rev-upgrade feature.

--->  No broken files found.

This confirms there's no real problem. The gcc48 port is successfully installed.

Also if it does build successfully, where will I find (location) the gcc executable?

port contents gcc48 will show you what files were installed.

comment:2 Changed 8 years ago by neverpanic (Clemens Lang)

Resolution: duplicate
Status: newclosed

Duplicate of #36996.

comment:3 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.