Opened 8 years ago

Closed 8 years ago

#37535 closed defect (fixed)

cppunit @1.12.1_0 configure fails due to automake 1.13

Reported by: tsmithtree@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: haspatch Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: cppunit

Description

Hi, I'm not sure if I should submit this problem here or upstream, but here goes...

cppunit @1.12.1_0 fails with the following error message:

:info:configure configure.in:40: error: 'AM_CONFIG_HEADER': this macro is obsolete.
:info:configure     You should use the 'AC_CONFIG_HEADERS' macro instead.
:info:configure /opt/local/share/aclocal-1.13/obsolete-err.m4:12: AM_CONFIG_HEADER is expanded from...
:info:configure configure.in:40: the top level
:info:configure autom4te: /opt/local/bin/gm4 failed with exit status: 1
:info:configure aclocal: error: echo failed with exit status: 1
:info:configure autoreconf: aclocal failed with exit status: 1
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_cppunit/cppunit/work/cppunit-1.12.1" && autoreconf --install -fvi 
:info:configure Exit code: 1

This seems to be caused by changes in automake 1.13. I have attached a small patch to fix the offending line in configure.in

Attachments (1)

patch-configure.in.diff (321 bytes) - added by tsmithtree@… 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by tsmithtree@…

Attachment: patch-configure.in.diff added

comment:1 Changed 8 years ago by tsmithtree@…

Cc: tsmithtree@… added

Cc Me!

comment:2 Changed 8 years ago by jmroot (Joshua Root)

Cc: tsmithtree@… removed
Owner: changed from macports-tickets@… to mww@…

Please remember to Cc the maintainer.

comment:3 Changed 8 years ago by tsmithtree@…

Appears to be fixed now...

comment:4 Changed 8 years ago by jmroot (Joshua Root)

Cc: jeremyhu@… added
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.