Opened 7 years ago

Last modified 2 years ago

#37592 new defect

digikam @2.9.0 flickr module cannot authenticate

Reported by: pb.mosca@… Owned by: jgosmann (Jan Gosmann)
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: cgilles (HumanDynamo)
Port: digikam

Description

The flickr exporter module of digikam cannot work on Mac OS X because the authentication process is broken: when launching for the first time the module, it tries to get an authorization token from flickr by opening a Web navigator. Unfortunately, on OS X, KWrite is opened instead of a Web browser.

Change History (7)

comment:1 Changed 7 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to jan@…

In the future, please Cc the port maintainer(s).

comment:2 Changed 7 years ago by pb.mosca@…

Noted, was'nt sure.

comment:3 Changed 7 years ago by jgosmann (Jan Gosmann)

Seems like you have a strange KDE default browser setting. Try do edit ~/Library/Preferences/KDE/share/config/kdeglobals and look for the section [General]. Is there a line starting with BrowserApplication and if yes, what does it say? Try do replace it with:

BrowserApplication[$e]=!/Applications/MacPorts/KDE4/konqueror.app/Contents/MacOS/konqueror

If such a line does not exist, append

[General]
BrowserApplication[$e]=!/Applications/MacPorts/KDE4/konqueror.app/Contents/MacOS/konqueror

to the file. Does that solve the problem?

comment:4 Changed 7 years ago by pb.mosca@…

I do not have konqueror installed and I cannot install konqueror (port search konqueror returns nothing).

However, thank you for pointing me out to this file, I did not know about it. I set the BrowserApplication variable to

BrowserApplication[$e]=!/Applications/Firefox.app/Contents/MacOS/firefox

And it works (however, you have to quit Firefox if it is already launched, otherwise it complains about an already running instance of Firefox).

comment:5 Changed 7 years ago by jgosmann (Jan Gosmann)

konqueror is part of kde4-baseapps. Maybe I should make that a dependency of digikam.

If you want to use Firefox it might also work with an already launched Firefox if you use

BrowserApplication[$e]=!open /Applications/Firefox.app

comment:6 in reply to:  5 Changed 7 years ago by pb.mosca@…

Replying to jan@…:

If you want to use Firefox it might also work with an already launched Firefox if you use

BrowserApplication[$e]=!open /Applications/Firefox.app

Indeed, thanks!

comment:7 Changed 2 years ago by jmroot (Joshua Root)

Cc: caulier.gilles@… added
Note: See TracTickets for help on using tickets.