Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#37643 closed update (fixed)

root @5.34.03_1: update to 5.34.04

Reported by: cjones051073 (Chris Jones) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch maintainer Cc: mattiafrancescomoro@…, g5pw (Aljaž Srebrnič)
Port: root

Description

  • Update ROOT to the latest 5.34.04 release
  • Add --disable-cocoa to the default configure argument list, to make sure it is disabled unless the cocoa variant is explicitly enabled.
  • Minor comment change...

Attachments (3)

root.diff (2.4 KB) - added by cjones051073 (Chris Jones) 8 years ago.
main.log (1.4 MB) - added by g5pw (Aljaž Srebrnič) 8 years ago.
Failed build with default variants+pythia
build.log (2.9 MB) - added by cjones051073 (Chris Jones) 8 years ago.

Change History (25)

Changed 8 years ago by cjones051073 (Chris Jones)

Attachment: root.diff added

comment:1 Changed 8 years ago by larryv (Lawrence Velázquez)

Cc: mattiafrancescomoro@… added
Summary: Update ROOT to 5.34.04root @5.34.03_1: update to 5.34.04
Version: 2.1.2

comment:2 Changed 8 years ago by g5pw (Aljaž Srebrnič)

I'm attaching a failed build log, with all variants selected. Error seems to be in the pythia variant.

comment:3 Changed 8 years ago by cjones051073 (Chris Jones)

your log file appears to be corrupted. Please do a clean rebuild ('sudo port clean root' first) and if it still files post the log file again.

comment:4 Changed 8 years ago by cjones051073 (Chris Jones)

also, please isolate the minimum set of variants that cause the failure. Do not just build with them all ...

comment:5 in reply to:  3 ; Changed 8 years ago by g5pw (Aljaž Srebrnič)

Replying to jonesc@…:

your log file appears to be corrupted. Please do a clean rebuild ('sudo port clean root' first) and if it still files post the log file again.

It is a clean logfile, I'm pretty sure i cleaned beforehand, and it looks like all phases are there, why do you say it's corrupted?

comment:6 in reply to:  4 Changed 8 years ago by g5pw (Aljaž Srebrnič)

Replying to jonesc@…:

also, please isolate the minimum set of variants that cause the failure. Do not just build with them all ...

I'm trying to isolate the problematic variant now. On a macbook, it does take some time... :)

comment:7 Changed 8 years ago by g5pw (Aljaž Srebrnič)

Cc: g5pw@… added

Cc Me!

comment:8 in reply to:  5 Changed 8 years ago by cjones051073 (Chris Jones)

Replying to g5pw@…:

Replying to jonesc@…:

your log file appears to be corrupted. Please do a clean rebuild ('sudo port clean root' first) and if it still files post the log file again.

It is a clean logfile, I'm pretty sure i cleaned beforehand, and it looks like all phases are there, why do you say it's corrupted?

no it is not. The last part I can read is

:info:build bin/rmkdepend -R -fcint/reflex/src/Base.d -Y -w 1000 -- -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONF

everything after that is unreadable. Or is it just me ... ?

Chris

comment:9 Changed 8 years ago by cjones051073 (Chris Jones)

just to clarify, when I say your log is not clean, I mean I simply cannot read it at all. It contains unreadable characters. not that you did not perform a clean port build.

Chris

Last edited 8 years ago by cjones051073 (Chris Jones) (previous) (diff)

comment:10 Changed 8 years ago by cjones051073 (Chris Jones)

just to clarify more. If I just download your log and cat it, I get

<snip>
:info:build clang++ -O2 -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONFIG     -pthread -o cint/reflex/src/Any.o -c /opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_dports_science_root/root/work/root/cint/reflex/src/Any.cxx
:info:build bin/rmkdepend -R -fcint/reflex/src/Array.d -Y -w 1000 -- -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONFIG     -pthread -D__cplusplus -- /opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_dports_science_root/root/work/root/cint/reflex/src/Array.cxx
:info:build bin/rmkdepend -R -fcint/reflex/src/Base.d -Y -w 1000 -- -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONF

that is it. everything after that is unreadable for some reason....

So it tells me nothing as is...

cheers Chris

comment:11 Changed 8 years ago by cjones051073 (Chris Jones)

Also, I have tried numerous combinations of variants, wth OSX 10.8 and Xcode 4.5.2 and they all work just fine for me ....

comment:12 in reply to:  10 ; Changed 8 years ago by g5pw (Aljaž Srebrnič)

Replying to jonesc@…:

just to clarify more. If I just download your log and cat it, I get

<snip>
:info:build clang++ -O2 -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONFIG     -pthread -o cint/reflex/src/Any.o -c /opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_dports_science_root/root/work/root/cint/reflex/src/Any.cxx
:info:build bin/rmkdepend -R -fcint/reflex/src/Array.d -Y -w 1000 -- -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONFIG     -pthread -D__cplusplus -- /opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_dports_science_root/root/work/root/cint/reflex/src/Array.cxx
:info:build bin/rmkdepend -R -fcint/reflex/src/Base.d -Y -w 1000 -- -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONF

that is it. everything after that is unreadable for some reason....

So it tells me nothing as is...

cheers Chris

Huh, that's strange. I'll try to rebuild and re-post the log. However, root with +avahi+clang31+cocoa+fftw3+fitsio+graphviz+gsl+ldap+minuit2+mysql55+opengl+postgresql92+python32+roofit+ruby+soversion+ssl+tmva+xml builds cleanly, so I suspect it's either pythia or qt_mac that causes the error. Will rebuild with just +pythia and post logs soon!

comment:13 in reply to:  12 Changed 8 years ago by g5pw (Aljaž Srebrnič)

Replying to g5pw@…:

Replying to jonesc@…:

just to clarify more. If I just download your log and cat it, I get

<snip>
:info:build clang++ -O2 -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONFIG     -pthread -o cint/reflex/src/Any.o -c /opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_dports_science_root/root/work/root/cint/reflex/src/Any.cxx
:info:build bin/rmkdepend -R -fcint/reflex/src/Array.d -Y -w 1000 -- -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONFIG     -pthread -D__cplusplus -- /opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_dports_science_root/root/work/root/cint/reflex/src/Array.cxx
:info:build bin/rmkdepend -R -fcint/reflex/src/Base.d -Y -w 1000 -- -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONF

that is it. everything after that is unreadable for some reason....

Huh, that's strange. I'll try to rebuild and re-post the log. However, root with +avahi+clang31+cocoa+fftw3+fitsio+graphviz+gsl+ldap+minuit2+mysql55+opengl+postgresql92+python32+roofit+ruby+soversion+ssl+tmva+xml builds cleanly, so I suspect it's either pythia or qt_mac that causes the error. Will rebuild with just +pythia and post logs soon!

comment:14 Changed 8 years ago by cjones051073 (Chris Jones)

The problem with your log might be the encoding, or you have created a binary file not a text file somehow... gedit gives me when I try and open it

gedit has not been able to detect the character coding.
Please check that you are not trying to open a binary file.
Select a character coding from the menu and try again.

Please make sure it is a proper text file.

Chris

Changed 8 years ago by g5pw (Aljaž Srebrnič)

Attachment: main.log added

Failed build with default variants+pythia

comment:15 in reply to:  14 Changed 8 years ago by g5pw (Aljaž Srebrnič)

Replying to jonesc@…:

The problem with your log might be the encoding, or you have created a binary file not a text file somehow... gedit gives me when I try and open it

gedit has not been able to detect the character coding.
Please check that you are not trying to open a binary file.
Select a character coding from the menu and try again.

Please make sure it is a proper text file.

Beats me, I haven't touched it! Maybe it got corrupted during upload? Anyway, I reuploaded the failed build log, this time with only +pythia variant enabled.

Last edited 8 years ago by g5pw (Aljaž Srebrnič) (previous) (diff)

comment:16 Changed 8 years ago by cjones051073 (Chris Jones)

did you manage to reproduce the build failure and create a new log ?

comment:17 in reply to:  16 Changed 8 years ago by g5pw (Aljaž Srebrnič)

Replying to jonesc@…:

did you manage to reproduce the build failure and create a new log ?

Yes, I overwrote the attached main.log I uploaded before (the corrupted one).

comment:18 Changed 8 years ago by cjones051073 (Chris Jones)

Hmmm. default variants + pythia builds fine for me. See the attached reference log.

I wonder if something is fishy in your pythia port installation. Can you please check it, reinstall it from scratch. This is the only thing I can think of looking at your errors. The failures are quite odd....

cheers Chris

Changed 8 years ago by cjones051073 (Chris Jones)

Attachment: build.log added

comment:19 Changed 8 years ago by cjones051073 (Chris Jones)

Also please confirm the default variants + pythia build fine with the correct released version, 5.34.03. Please post a build log for that version.

Chris

comment:20 Changed 8 years ago by cjones051073 (Chris Jones)

If you still have failures after checking your pythia port, please check what is in your version of

/opt/local/include/Analysis.h

as the first error you get is

:info:build /opt/local/include/Analysis.h:38:22: error: unknown type name 'Event'; did you mean 'event'?

for me, this file starts with

#ifndef Pythia8_Analysis_H
#define Pythia8_Analysis_H

#include "Basics.h"
#include "Event.h"
#include "PythiaStdlib.h"

and the compile command is

:info:build clang++ -O2 -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONFIG     -pthread -I/opt/local/include -o montecarlo/pythia8/src/TPythia8.o -c /opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_dports_science_root/root/work/root/montecarlo/pythia8/src/TPythia8.cxx

so the include for Event.h should be found via the -I/opt/local/include which for me does include Event.h .... Why your build is failing is a bit odd...

Chris

comment:21 in reply to:  20 Changed 8 years ago by g5pw (Aljaž Srebrnič)

Resolution: fixed
Status: newclosed

Replying to jonesc@…:

If you still have failures after checking your pythia port, please check what is in your version of

/opt/local/include/Analysis.h

for me, this file starts with

#ifndef Pythia8_Analysis_H
#define Pythia8_Analysis_H

#include "Basics.h"
#include "Event.h"
#include "PythiaStdlib.h"

Yap, same here!

and the compile command is

:info:build clang++ -O2 -m64 -pipe -Wshadow -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -DR__HAVE_CONFIG     -pthread -I/opt/local/include -o montecarlo/pythia8/src/TPythia8.o -c /opt/local/var/macports/build/_opt_local_var_macports_sources_svn.macports.org_dports_science_root/root/work/root/montecarlo/pythia8/src/TPythia8.cxx

so the include for Event.h should be found via the -I/opt/local/include which for me does include Event.h .... Why your build is failing is a bit odd...

Chris

Hmm.. that's quite suspicious. I have a similar failure with another port I was making, which seemed not to include headers which were in fact #include'd. very strange!

Since this looks like a problem on my machine, I commited your diff to the repo in r101697. I'll investigate some more and eventually reopen the ticket if I find something out.

comment:22 Changed 8 years ago by cjones051073 (Chris Jones)

Great thanks ! I agree this sounds like some oddity with your machine, hope you find it ;)

Note: See TracTickets for help on using tickets.