Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#37806 closed defect (duplicate)

firefox-x11 @7.0.1_2: error: non-constant-expression cannot be narrowed from type 'int' to 'SInt8' (aka 'signed char') in initializer list [-Wc++11-narrowing]

Reported by: cdcooke@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: Cc: cooljeanius (Eric Gallager)
Port: firefox-x11

Description

Having trouble building firefox-x11. Gives me this error:

cdcooke$ sudo port install firefox-x11
--->  Computing dependencies for firefox-x11
--->  Fetching archive for firefox-x11
--->  Attempting to fetch firefox-x11-7.0.1_2.darwin_12.x86_64.tbz2 from http://packages.macports.org/firefox-x11
--->  Attempting to fetch firefox-x11-7.0.1_2.darwin_12.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/firefox-x11
--->  Attempting to fetch firefox-x11-7.0.1_2.darwin_12.x86_64.tbz2 from http://lil.fr.packages.macports.org/firefox-x11
--->  Attempting to fetch firefox-x11-7.0.1_2.darwin_12.x86_64.tbz2 from http://jog.id.packages.macports.org/macports/packages/firefox-x11
--->  Fetching distfiles for firefox-x11
--->  Verifying checksum(s) for firefox-x11
--->  Extracting firefox-x11
--->  Applying patches to firefox-x11
--->  Configuring firefox-x11
--->  Building firefox-x11
Error: org.macports.build for port firefox-x11 returned: command execution failed
Please see the log file for port firefox-x11 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_firefox-x11/firefox-x11/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port firefox-x11 failed

Attached is the log. Any suggestions?

Attachments (1)

main.log (3.6 MB) - added by cdcooke@… 8 years ago.
error log supplied when build fails

Change History (3)

Changed 8 years ago by cdcooke@…

Attachment: main.log added

error log supplied when build fails

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Summary: Can't get firefox-x11 to buildfirefox-x11 @7.0.1_2: error: non-constant-expression cannot be narrowed from type 'int' to 'SInt8' (aka 'signed char') in initializer list [-Wc++11-narrowing]

Looks like clang has some complaints, the first of which is:

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_firefox-x11/firefox-x11/work/mozilla-release/ipc/chromium/src/base/message_pump_mac.mm:237:5: error: non-constant-expression cannot be narrowed from type 'int' to 'SInt8' (aka 'signed char') in initializer list [-Wc++11-narrowing]
:info:build     exploded.month,
:info:build     ^~~~~~~~~~~~~~

So this is a duplicate of #35145.

comment:2 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.