Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#3787 closed defect (fixed)

NEW: hellanzb-0.6

Reported by: pjenvey@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: branana@…
Port:

Description

hellanzb-0.6

the portfile can be found here: http://groovie.org/~pjenvey/hellanzb-0.6/Portfile

Description: Nzb downloader and post processor

Homepage: http://www.hellanzb.com

Comments: As a python port maintainer, I have noticed python24's harcoded dependency on tk is not at all beneficial to python ports like mine. Installing a rather small python app such as hellanzb triggers:

o python2.4 installation (This may seem overkill to a casual observer, as the app could get by with OS X's base python. However it's necessary for a couple dependencies/and we'll need a darwinport python installed since we are a 'PortGroup python' port anyway, so this is understandable) o tcl is installed as a tk dependency o tk is installed

The last two hellanzb did not need, and in this case only serve to lengthen hellanzb's installation -- significantly so unless we're on a g5 tower and don't care

I'm sure the dependency is there for a reason, like an already existing port requires python24 with tk installed

This situation would benefit from allowing ports to depend on variants. Are there plans for this or other similar solutions in the future?

Thanks

Change History (3)

comment:1 Changed 15 years ago by mww@…

Resolution: fixed
Status: newclosed
  1. python24 now doesnt need tk anymore, we now have a py-tkinter port for the tk module (I assume this

will make some people happy..)

  1. commited

comment:2 Changed 15 years ago by mww@…

Cc: branana@… added

comment:3 Changed 15 years ago by mww@…

* Bug 3775 has been marked as a duplicate of this bug. *

Note: See TracTickets for help on using tickets.