Opened 8 years ago

Closed 8 years ago

#37964 closed defect (fixed)

py*-lz4, py*-html2text: need dependencies on py*-distribute

Reported by: cooljeanius (Eric Gallager) Owned by: seanfarley (Sean Farley)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: py-lz4 py-html2text

Description

When installing the various py*-lz4 ports and the py*-html2text ports, I got the following error:

DEBUG: Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py-html2text/py33-html2text/work/html2text-8ddc844b0304" && /opt/local/Library/Frameworks/Python.framework/Versions/3.3/bin/python3.3 setup.py --no-user-cfg build 
Traceback (most recent call last):
  File "setup.py", line 2, in <module>
    from setuptools import setup, find_packages
ImportError: No module named 'setuptools'

After installing the respective py*-distribute ports, the previous ports installed successfully

Change History (7)

comment:1 Changed 8 years ago by larryv (Lawrence Velázquez)

Cc: sean@… removed
Owner: changed from macports-tickets@… to sean@…

Build dependencies, or both build and run?

comment:2 Changed 8 years ago by cooljeanius (Eric Gallager)

idk, build at least, I haven't tried running them without yet... I'd have to uninstall my py*-distribute ports first to test...

comment:3 Changed 8 years ago by cooljeanius (Eric Gallager)

OK, I've tested py27-html2text at least; that at least needs py27-distribute as a runtime dependency in addition to as a build one; py27-lz4, on the other hand, I couldn't test because it only installs a library, not an executable, so I'd have to actually write some code if I wanted to test it...

comment:4 Changed 8 years ago by larryv (Lawrence Velázquez)

Summary: py*-lz4 and py*-html2text need dependencies on py*-distributepy*-lz4, py*-html2text: need build dependencies on py*-distribute
Version: 2.1.3

I ran a couple of LZ4 functions in the Python REPL after uninstalling distribute, and it works fine.

comment:5 Changed 8 years ago by larryv (Lawrence Velázquez)

Summary: py*-lz4, py*-html2text: need build dependencies on py*-distributepy*-lz4, py*-html2text: need dependencies on py*-distribute

Oops; asleep at the wheel there.

comment:6 Changed 8 years ago by cooljeanius (Eric Gallager)

fixed as of r103128 and r103129

comment:7 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.