Opened 7 years ago

Closed 7 years ago

#37971 closed defect (fixed)

fuse4x: missing libiconv dependency

Reported by: ryandesign (Ryan Schmidt) Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc:
Port: fuse4x

Description

fuse4x needs a libiconv library dependency because libfuse.dylib does link with libiconv.dylib:

$ otool -L /opt/local/lib/libfuse.dylib
/opt/local/lib/libfuse.dylib:
	/opt/local/lib/libfuse.2.dylib (compatibility version 11.0.0, current version 11.7.0)
	/opt/local/lib/libiconv.2.dylib (compatibility version 8.0.0, current version 8.1.0)
	/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 744.12.0)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 169.3.0)

The port's revision should be increased.

Change History (2)

comment:1 Changed 7 years ago by drkp (Dan Ports)

Status: newassigned

comment:2 Changed 7 years ago by drkp (Dan Ports)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.