Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#37982 closed defect (duplicate)

lcms, lcms2: fails to compile against jpeg 9

Reported by: blair (Blair Zajac) Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: adfernandes (Andrew Fernandes), ryandesign (Ryan Schmidt), nick.fabry@…, murrayeisenberg@…, sewebster@…, crossd@…, irony42@…, mauxnet@…, janusofzeal@…
Port: lcms, lcms2

Description

Recompiling jpeg's dependent ports, got this failure:

make[1]: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_lcms2/lcms2/work/lcms2-2.4/utils/jpgicc'
/usr/bin/clang -DPACKAGE_NAME=\"lcms2\" -DPACKAGE_TARNAME=\"lcms2\" -DPACKAGE_VERSION=\"2.4\" -DPACKAGE_STRING=\"lcms2\ 2.4\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHasJPEG=1 -DHasZLIB=1 -DHasTIFF=1 -DHAVE_TIFFCONF_H=1 -I.  -I../../include -I../../include -I../../utils/common -I../../utils/common -I/opt/local/include  -pipe -O2 -arch x86_64 -MT jpgicc.o -MD -MP -MF .deps/jpgicc.Tpo -c -o jpgicc.o jpgicc.c
In file included from jpgicc.c:30:
In file included from /opt/local/include/jpeglib.h:27:
/opt/local/include/jmorecfg.h:263:16: error: expected '}'
typedef enum { FALSE = 0, TRUE = 1 } boolean;
               ^
../../include/lcms2.h:227:22: note: expanded from macro 'FALSE'
#       define FALSE 0
                     ^
/opt/local/include/jmorecfg.h:263:14: note: to match this '{'
typedef enum { FALSE = 0, TRUE = 1 } boolean;
             ^
jpgicc.c:1094:42: warning: data argument not used by format string [-Wformat-extra-args]
                     SW, SW, SW, SW, SW, SW);
                                         ^
1 warning and 1 error generated.
make[1]: *** [jpgicc.o] Error 1

Change History (14)

comment:1 Changed 4 years ago by blair (Blair Zajac)

BTW, this is on 10.7.

comment:2 Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Cc adfernandes@… ryandesign@… added
  • Port lcms added
  • Summary changed from lcms2 fails to compile against new jpeg to lcms, lcms2: fails to compile against jpeg 9

I get the same on 10.5 and 10.8, and also with lcms.

comment:3 follow-up: Changed 4 years ago by ryandesign (Ryan Schmidt)

Do lcms/lcms2 need a fix like tiff got in r102823?

wxWidgets is also affected; #37983

povray looks to be affected; #37985

comment:4 in reply to: ↑ 3 ; follow-up: Changed 4 years ago by crossd@…

Replying to ryandesign@…:

Do lcms/lcms2 need a fix like tiff got in r102823?

wxWidgets is also affected; #37983

povray looks to be affected; #37985

openmotif is also affected.

comment:5 Changed 4 years ago by larryv (Lawrence Velázquez)

  • Cc nick.fabry@… murrayeisenberg@… added

Has duplicates #37986 and #37987.

comment:6 Changed 4 years ago by sewebster@…

  • Cc sewebster@… added

Cc Me!

comment:7 in reply to: ↑ 4 ; follow-up: Changed 4 years ago by irony42@…

Replying to crossd@…:

Replying to ryandesign@…:

Do lcms/lcms2 need a fix like tiff got in r102823?

wxWidgets is also affected; #37983

povray looks to be affected; #37985

openmotif is also affected.

libmng and poppler are also affected.

comment:8 in reply to: ↑ 7 ; follow-up: Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Cc crossd@… irony42@… added

Replying to crossd@…:

openmotif is also affected.

Please file individual tickets for each separate port that itself fails to build with jpeg 9, since at this point I'm assuming an individual fix will be needed for each affected port.

openmotif: #37989

gdal: #37988

Replying to irony42@…:

libmng and poppler are also affected.

libmng depends on lcms and poppler depends on lcms2, so it's hard to know whether libmng and poppler themselves fail to build with jpeg 9 until we resolve the issues with lcms and lcms2.

comment:9 in reply to: ↑ 8 Changed 4 years ago by irony42@…

Replying to ryandesign@…:

Replying to irony42@…:

libmng and poppler are also affected.

libmng depends on lcms and poppler depends on lcms2, so it's hard to know whether libmng and poppler themselves fail to build with jpeg 9 until we resolve the issues with lcms and lcms2.

Right. On second glance, it looks like just poppler has an independent issue... we'll see.

comment:10 Changed 4 years ago by pingemi@…

I thought it odd that JPEG 9 assumes if there's no boolean type, then TRUE and FALSE aren't defined. So in /opt/local/include/jmorecfg.h I replaced:

typedef enum { FALSE = 0, TRUE = 1 } boolean;

with:

#ifndef TRUE
#ifndef FALSE
typedef enum { FALSE = 0, TRUE = 1 } boolean;
#else
typedef int boolean;
#endif
#else
typedef int boolean;
#endif

seems to work fine.

comment:11 Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Cc mauxnet@… added

Has duplicate #37991.

comment:12 Changed 4 years ago by janusofzeal@…

  • Cc janusofzeal@… added

Cc Me!

comment:13 Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #37984.

comment:14 Changed 4 years ago by ryandesign (Ryan Schmidt)

Has duplicate #37993.

Note: See TracTickets for help on using tickets.