Opened 8 years ago

Closed 8 years ago

#38032 closed defect (duplicate)

shogun installation error using macports

Reported by: kyunghee.kim@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc:
Port: shogun

Description (last modified by ryandesign (Ryan Schmidt))

Does anyone know how to resolve this problem?

Error: Processing of port py26-pymvpa failed 
macports.org_release_ports_math_shogun/shogun/main.logar_macports_sources_rsync.m 

:info:build Undefined symbols for architecture x86_64:
:info:build   "_drot_", referenced from:
:info:build       _dbdsqr_ in liblapack.a(dbdsqr.o)
:info:build   "_dswap_", referenced from:
:info:build       _dbdsqr_ in liblapack.a(dbdsqr.o)
:info:build       _dsteqr_ in liblapack.a(dsteqr.o)
:info:build      (maybe you meant: _ATL_dswap_xp0yp0aXbX)
:info:build   "__gfortran_concat_string", referenced from:
:info:build       _dgesvd_ in liblapack.a(dgesvd.o)
:info:build       _dormbr_ in liblapack.a(dormbr.o)
:info:build       _dormqr_ in liblapack.a(dormqr.o)
:info:build       _dormlq_ in liblapack.a(dormlq.o)
:info:build   "_dgemm_", referenced from:  
:info:build       _dgesvd_ in liblapack.a(dgesvd.o)
:info:build       _dgebrd_ in liblapack.a(dgebrd.o)
:info:build   "_dgemv_", referenced from:
:info:build       _dlabrd_ in liblapack.a(dlabrd.o)
:info:build       _dlatrd_ in liblapack.a(dlatrd.o)
:info:build       _dlarf_ in liblapack.a(dlarf.o)
:info:build   "_dger_", referenced from:
:info:build       _dlarf_ in liblapack.a(dlarf.o)
:info:build      (maybe you meant: _ATL_dger_L1, _ATL_dger_L2 , _ATL_dger_OOC )
:info:build   "_dnrm2_", referenced from:
:info:build       _dlarfg_ in liblapack.a(dlarfg.o)
:info:build      (maybe you meant: _ATL_dnrm2_xp1yp0aXbX, _ATL_dnrm2_xp0yp0aXbX )
:info:build   "_dcopy_", referenced from:
:info:build       _dlasq1_ in liblapack.a(dlasq1.o)
:info:build      (maybe you meant: _ATL_dcopy_xp1yp1aXbX, _ATL_dcopy_xp0yp0aXbX )

Change History (1)

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: shogun added
Resolution: duplicate
Status: newclosed

Duplicate of #34990.

Note: See TracTickets for help on using tickets.