Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#38453 closed update (fixed)

Hydra 5.4_3 updated to 7.4.2

Reported by: zan@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: haspatch Cc: openandreaponza@…, ryandesign (Ryan Schmidt), raimue (Rainer Müller)
Port: hydra

Description

Updated hydra to version 7.4.2 from 5.4_3, which is over 2 years old.

  • Hydra does no longer compile with old dependency libssh01, use libssh instead.
  • Added other dependencies.
  • Removed patch file, files directory is now empty.

Attachments (2)

patch-configure.diff (3.1 KB) - added by zan@… 10 years ago.
Portfile.diff (10.4 KB) - added by zan@… 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: openandreaponza@… added; nomaintainer@… removed
Keywords: haspatch added
Port: hydra added; Hydra removed

Does this patch address all the concerns raised in #36370?

comment:2 Changed 10 years ago by zan@…

I was not aware of ticket #36370, but I was considering the same issues. I've updated the Portfile patch and attached a new patch for configure to address the issues raised in #36370.

  • All extensions except basic functionality are disabled.
  • Extensions are added back in by setting variants (psql8x, 9x, mysql5x, subversion, xhydra for gui).
  • Several extensions to hydra are not in Macports, but they could be if someone would create a port for it. These are FirebirdSQL (http://www.firebirdsql.org/), Apple Filing Protocol (relies on a FUSE plugin, https://sites.google.com/site/alexthepuffin/), and Netware Core Protocol (http://prope.insa-lyon.fr/~ppollet/ncpfs/). I have created commented-out place holders for variants for those.
  • Two other extensions are not in Macports and never will be: Oracle DB and SAP. They could, however, be installed by the user, but an end user has no way of telling this port where those packages are installed without editing the port file. Disabled searching for both.
  • There is one strange search for Kerberos inclusion, see comments in Portfile.

Finally, I do not understand the last line in the comment 3 of #36370: "Also, make sure the configure script picks up all libraries from /usr and not from ${prefix}." Surely, that should be the opposite, right? We want to pick up all libraries from Macports, no outside dependencies?

comment:3 in reply to:  2 ; Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… raimue@… added

Replying to zan@…:

  • Two other extensions are not in Macports and never will be: Oracle DB and SAP.

Can it use oracle-instantclient? We do have a port for that which is already used by a half dozen other ports.

Finally, I do not understand the last line in the comment 3 of #36370: "Also, make sure the configure script picks up all libraries from /usr and not from ${prefix}." Surely, that should be the opposite, right? We want to pick up all libraries from Macports, no outside dependencies?

I agree; I assume that's a typo. (Rainer?)

comment:4 in reply to:  3 Changed 10 years ago by zan@…

Replying to ryandesign@…:

Can it use oracle-instantclient? We do have a port for that which is already used by a half dozen other ports.

Yes it can. Updated the Portfile patch to include an oracle variant with dependency on oracle-instantclient.

Also updated configure patch with the following change. Math.h is searched for while searching for mysql and mysql is disabled if math.h is not found, but math.h is also used for password generation routines. Leave search for math.h in while deleting mysql if not requested.

Changed 10 years ago by zan@…

Attachment: patch-configure.diff added

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

The psqlXX variants should be renamed to match the port names (postgresqlXX).

In addition to the mysql51 and mysql55 variants, there should be mysql5, mariadb and percona variants; all 5 should conflict with one another.

comment:6 in reply to:  5 Changed 10 years ago by zan@…

Replying to ryandesign@…:

The psqlXX variants should be renamed to match the port names (postgresqlXX).

In addition to the mysql51 and mysql55 variants, there should be mysql5, mariadb and percona variants; all 5 should conflict with one another.

Updated Portfile patch with new variant names (postgresqlXX and subversion) and added mysql5, mariadb, and percona.

Changed 10 years ago by zan@…

Attachment: Portfile.diff added

comment:7 in reply to:  3 Changed 10 years ago by raimue (Rainer Müller)

Replying to ryandesign@…:

Replying to zan@…:

Finally, I do not understand the last line in the comment 3 of #36370: "Also, make sure the configure script picks up all libraries from /usr and not from ${prefix}." Surely, that should be the opposite, right? We want to pick up all libraries from Macports, no outside dependencies?

I agree; I assume that's a typo. (Rainer?)

Sorry for the late reply and sorry for the confusion caused by this statement. Of course I actually meant it the other way around.

comment:8 Changed 9 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: newclosed

Committed along with an update to 7.5 in r110688. I also fixed the build of xhydra, which failed without pkg-config and wasn't UsingTheRightCompiler without $CC set in the build environment.

comment:9 Changed 9 years ago by jmroot (Joshua Root)

The license is wrong, it's AGPLv3 with an OpenSSL linking exception. Fixed in r112302.

Note: See TracTickets for help on using tickets.