Opened 9 years ago

Closed 9 years ago

#38459 closed defect (duplicate)

HandBrake fails to build

Reported by: zeael@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc:
Port: HandBrake

Description

I unsuccessfully tried to install HandBrake via MacPorts today. clang, llvm-gcc-4.2 and apple-gcc-4.2 all produce the same error ("Error 65"), as can be seen in the attached log. I found a similar ticket (#32803), but over there, the problem could be solved by switching to apple-gcc-4.2.

End of the log:

:info:build ** BUILD FAILED **
:info:build 
:info:build 
:info:build The following build commands failed:
:info:build     ExternalBuildToolExecution external
:info:build (1 failure)
:info:build make: *** [macosx.build] Error 65
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/work/HandBrake-0.9.8/build'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_aqua_HandBrake/HandBrake/work/HandBrake-0.9.8/build" && /usr/bin/make -j2 -w 
:info:build Exit code: 2
:error:build org.macports.build for port HandBrake returned: command execution failed
:debug:build Error code: CHILDSTATUS 56979 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"

Attachments (1)

main.log (109.8 KB) - added by zeael@… 9 years ago.
main.log

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by zeael@…

Attachment: main.log added

main.log

comment:1 Changed 9 years ago by zeael@…

I'm sorry, duplicate of #37434 ...

comment:2 Changed 9 years ago by larryv (Lawrence Velázquez)

Keywords: handbrake removed
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.