Opened 7 years ago

Closed 7 years ago

#38553 closed defect (duplicate)

kde @3.5.10 depends on autoconf version conflicting with kdebase3

Reported by: macports.org@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc:
Port: kdebase3

Description

kde @3.5.10 depends on autoconf263 and kdebase3, but kdebase3 @3.5.10 needs autoconf => 2.65 thus kdebase3 fails to build.

kdebase3 fails with the following in the log:

:info:build aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
:info:build acinclude.m4:3724: warning: the serial number must appear before any macro definition
:info:build acinclude.m4:3769: warning: the serial number must appear before any macro definition
:info:build acinclude.m4:3814: warning: the serial number must appear before any macro definition
:info:build acinclude.m4:6007: warning: the serial number must appear before any macro definition
:info:build configure.in:43: error: Autoconf version 2.65 or higher is required
:info:build /opt/local/share/aclocal-1.13/init.m4:23: AM_INIT_AUTOMAKE is expanded from...
:info:build configure.in:43: the top level
:info:build autom4te263: /opt/local/bin/gm4 failed with exit status: 63
:info:build aclocal: error: echo failed with exit status: 63
:info:build make: *** [cvs] Error 1
:info:build kdebase3-3.5.10-7 cvs failed!

Is there a reason that kde depends on autoconf263 and not on autoconf?

Change History (2)

comment:1 Changed 7 years ago by macports.org@…

Please see also Bug #38554.

comment:2 Changed 7 years ago by jmroot (Joshua Root)

Keywords: kde dependency autoconf autoconf263 removed
Port: kdebase3 added; kde removed
Resolution: duplicate
Status: newclosed

The 'kde' port does not depend on any version of autoconf.

Note: See TracTickets for help on using tickets.