Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#38669 closed update (fixed)

Update for major security issue in PostgreSQL 9

Reported by: macports.org@… Owned by: macports-tickets@…
Priority: High Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: mww@…, jyrkiwahlstedt
Port: postgresql84, postgresql90, postgresql91, postgresql92

Description

The PostgreSQL team just released versions 9.2.4, 9.1.9, 9.0.13 and 8.4.17: http://www.postgresql.org/about/news/1456/

The post important part is fixes to the 9.x series for CVE-2013-1899 which allows DoS, privilege escalation and arbitrary code execution especially of publicly visible PostgreSQL servers: http://www.postgresql.org/support/security/faq/2013-04-04/

8.4 isn't exposed to this specific vulnerability, though 8.4.17 provides other security fixes for it in various contexts

Change History (3)

comment:1 Changed 8 years ago by jyrkiwahlstedt

Resolution: fixed
Status: newclosed

done in r104868, r104869, r104872 and r104873

comment:2 Changed 8 years ago by macports.org@…

Wow, thanks for the ultra-fast resolution.

comment:3 Changed 8 years ago by jyrkiwahlstedt

No problem, I was prepared (thanks to the core people having us in the proper mailing list), so I was done, when I saw the ticket!

Note: See TracTickets for help on using tickets.