Opened 8 years ago

Closed 3 years ago

#38746 closed defect (duplicate)

no action from MacPorts IDLE

Reported by: johnsankey@… Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: petrrr, cooljeanius (Eric Gallager), 1-61803
Port: python27

Description

I removed all python-site python bits from my system, deleted /opt, reinstalled OSX + Xcode + DSK, verified that no python 2.7 remained anywhere but that the three Apple versions were there, installed MacPorts, installed MacPorts WINE (I need it), installed Macports python27+py27-numpy+py27-scipy, then MacPorts opencv +python27. The only IDLE.app I have now is in /Applications/MacPorts/Python 2.7

Double-clicking it does nothing. Linking it to the .py prefix with Finder (going through the directories to ensure that it was this IDLE that was linked) then double-clicking the file also does nothing.

IDLE & this version of Python are needed for a course I'm taking. How do I get it to work the way it's supposed to?

Change History (15)

comment:1 in reply to:  description Changed 8 years ago by ryandesign (Ryan Schmidt)

Replying to johnsankey@…:

Double-clicking it does nothing.

Is any relevant message generated in the Console application at the time that you double-click it?

comment:2 Changed 8 years ago by larryv (Lawrence Velázquez)

I can reproduce this on 10.8 with python27 @2.7.3_1. Judging from this…

% /opt/local/bin/idle2.7
** IDLE can't import Tkinter.  Your Python may not be configured for Tk. **
%

…I think you need to install py27-tkinter also.

comment:3 Changed 8 years ago by johnsankey@…

Many thanks, larryv - that did it. It sure has been a frustrating two weeks...

Of course, might I suggest that py27-tkinter be included in the dependencies list for python27? And, you might consider it appropriate to issue a warning about the incompatibility of the python-site Python and MacPorts given the experience I reported in ticket #38560.

comment:4 in reply to:  3 Changed 8 years ago by mf2k (Frank Schima)

Replying to johnsankey@…:

Of course, might I suggest that py27-tkinter be included in the dependencies list for python27?

It cannot because py27-tkinter depends on python27.

comment:5 Changed 8 years ago by mf2k (Frank Schima)

Keywords: python27 idle.app removed
Port: opencv removed

comment:6 Changed 8 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to jwa@…

comment:7 in reply to:  3 ; Changed 8 years ago by larryv (Lawrence Velázquez)

Replying to johnsankey@…:

Of course, might I suggest that py27-tkinter be included in the dependencies list for python27?

The thing is, the Tk bindings were intentionally split out so that users would not be forced to install Tcl and Tk just to get Python.

comment:8 Changed 8 years ago by jmroot (Joshua Root)

Maybe the fact that IDLE needs the separate tkinter port should be mentioned in the notes?

comment:9 in reply to:  7 Changed 8 years ago by jmroot (Joshua Root)

Replying to larryv@…:

The thing is, the Tk bindings were intentionally split out so that users would not be forced to install Tcl and Tk just to get Python.

It's true that some users had asked for it on this basis, but the thing that actually triggered the change was a dependency loop involving libxcb.

comment:10 Changed 7 years ago by petrrr

Cc: Peter.Danecek@… added

Cc Me!

comment:11 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:12 Changed 5 years ago by 1-61803

Cc: iamsudo@… added

Cc Me!

comment:13 Changed 3 years ago by jmroot (Joshua Root)

Owner: changed from jyrkiwahlstedt to jmroot
Status: newassigned

comment:14 Changed 3 years ago by sideeffect42 (Takashi Yoshi)

Any progress regarding this issue (or #42191)?

comment:15 in reply to:  14 Changed 3 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: assignedclosed

Replying to sideeffect42:

Any progress regarding this issue (or #42191)?

Nope. IDLE still requires Tkinter which still can't be included in the python ports due to circular dependencies. I'll close this ticket since the other one has a better summary.

Patches would be welcome to provide IDLE as a separate port.

Note: See TracTickets for help on using tickets.