Opened 7 years ago

Closed 7 years ago

#38949 closed defect (duplicate)

perl5.12 +universal doesn't compile on 10.6.8

Reported by: tyson@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc:
Port: perl5.12

Description

The most recent perl5.12+universal update doesn't compile on my 10.6.8 system:

ld: in /opt/local/lib/libstdc++.6.dylib, file was built for unsupported file format which is not the architecture being linked (i386) for architecture i386
collect2: ld returned 1 exit status
lipo: can't open input file: /var/tmp//ccsXWm3h.out (No such file or directory)
make: *** [miniperl] Error 1
make: *** Waiting for unfinished jobs....
make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_perl5.12/perl5.12/work/perl-5.12.4'
Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_perl5.12/perl5.12/work/perl-5.12.4" && /usr/bin/make -j4 -w all 
Exit code: 2
Error: org.macports.build for port perl5.12 returned: command execution failed
Warning: targets not executed for perl5.12: org.macports.install org.macports.build org.macports.destroot
Please see the log file for port perl5.12 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_lang_perl5.12/perl5.12/main.log
Error: Unable to upgrade port: 1

See full build log attached.

Attachments (1)

build.log (45.8 KB) - added by tyson@… 7 years ago.
Build log

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by tyson@…

Attachment: build.log added

Build log

comment:1 Changed 7 years ago by cooljeanius (Eric Gallager)

This issue has been being reported a lot recently...

comment:2 Changed 7 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: newclosed

Duplicate of #36438.

Note: See TracTickets for help on using tickets.