Opened 5 years ago

Last modified 5 years ago

#38958 new defect

R @3.0.0_0: build failure on OS X 10.6.8

Reported by: volcdavis@… Owned by: kjellpk (Kjell Konis)
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: snowleopard Cc: cooljeanius (Eric Gallager), gregbg@…
Port: R

Description

Build of R-app fails when accessing devQuartz.c on 10.6.8. [Apparently it works on 10.8] See attached log.

Attachments (1)

main.log (291.2 KB) - added by volcdavis@… 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by volcdavis@…

comment:1 Changed 5 years ago by larryv (Lawrence Velázquez)

  • Keywords snowleopard added; R-app removed
  • Owner changed from macports-tickets@… to kjell.konis@…
  • Port @3.0.0 removed
  • Summary changed from R-app fails to build on OS X 10.6.8 to R-app @3.0.0: build failure on OS X 10.6.8

Thanks. In the future, please Cc relevant port maintainers.

comment:2 Changed 5 years ago by cooljeanius (Eric Gallager)

  • Cc egall@… added

Cc Me!

comment:3 Changed 5 years ago by kjellpk (Kjell Konis)

Maintainer here. It looks like this is actually a problem with the R port and not with R-app. The good news is that the R port does build (at least for me) on Snow Leopard using gcc47 which is now the default. The bad news is that I am not able to build the R-app port on Snow Leopard at all.

comment:4 Changed 5 years ago by volcdavis@…

After reading your comment, I upgraded to gcc47 and was able to build R. So the issue must be with the +gcc45 variant (which I was previously using).

comment:5 Changed 5 years ago by larryv (Lawrence Velázquez)

  • Cc gregbg@… added
  • Port R added; R-app removed
  • Summary changed from R-app @3.0.0: build failure on OS X 10.6.8 to R @3.0.0_0: build failure on OS X 10.6.8

Has duplicate #39343.

Note: See TracTickets for help on using tickets.