Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#39016 closed defect (duplicate)

perl5.12 @5.12.4_2 +universal fails to build

Reported by: dstrubbe (David Strubbe) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: ghosthound
Port: perl5.12

Description

This port fails to build with the error below in main.log. See full log attached. This was after doing "clean --all". I will note that I have the non-universal version installed already, which might be related.

:info:build /usr/bin/clang -L/opt/local/lib -arch x86_64 -arch i386 -fstack-protector -force_flat_namespace -o miniperl \
:info:build           gv.o toke.o perly.o pad.o regcomp.o dump.o util.o mg.o reentr.o mro.o hv.o av.o run.o pp_hot.o sv.o pp.o scope.o pp_ctl.o pp_sys.o doop.o doio.o regexec.o utf8.o taint.o deb.o universal.o globals.o perlio.o perlapi.o numeric.o mathoms.o locale.o pp_pack.o pp_sort.o   \
:info:build         miniperlmain.o opmini.o perlmini.o -ldl -lm -lutil -lc 
:info:build ld: in /opt/local/lib/libstdc++.6.dylib, file was built for unsupported file format ( 0xcf 0xfa 0xed 0xfe 0x 7 0x 0 0x 0 0x 1 0x 3 0x 0 0x 0 0x 0 0x 6 0x 0 0x 0 0x 0 ) which is not the architecture being linked (i386): /opt/local/lib/libstdc++.6.dylib for architecture i386
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build make: *** [miniperl] Error 1

Attachments (1)

main.log (125.4 KB) - added by dstrubbe (David Strubbe) 8 years ago.

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by dstrubbe (David Strubbe)

Attachment: main.log added

comment:1 Changed 8 years ago by cooljeanius (Eric Gallager)

This has been getting reported a lot lately...

comment:2 in reply to:  1 Changed 8 years ago by larryv (Lawrence Velázquez)

Cc: ricci@… added
Resolution: duplicate
Status: newclosed

Replying to egall@…:

This has been getting reported a lot lately...

Yes, it has been. Please search Trac before posting new tickets; there have been a number of tickets about this very issue. They are all duplicates of #36438. The current workaround is to force-deactivate libstdcxx or libstdcxx-devel for the duration of the upgrade.

comment:3 Changed 8 years ago by dstrubbe (David Strubbe)

Ok, I did search Trac. I found no tickets on this subject filed against perl5.12. (https://trac.macports.org/report/16?max=100&PORT=perl5.12) I guess the problem is that search returns only open tickets, and the ticket you refer to does not list perl5.12 in the 'ports' field.

Note: See TracTickets for help on using tickets.