Opened 8 years ago

Closed 8 years ago

#39021 closed defect (duplicate)

apple-gcc40 @5494_0 post-installation check is complaining about premature end of file

Reported by: snowflake (Dave Evans) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: rev-upgrade Cc:
Port: apple-gcc40

Description

I installed apple-gcc40 via a binary archive from one of the mirrors

http://mse.uk.packages.macports.org/sites/packages.macports.org/apple-gcc40/

I have no reason to suspect the archive as it passed a bzip2 -t check and it also passed the rmd160 signature.

After the installation, port ran a check on the installed files with this result:

--->  Cleaning apple-gcc40
--->  Scanning binaries for linking errors: 99.7%
Warning: Error parsing file /opt/local/lib/apple-gcc40/lib/gcc/i686-apple-darwin12.2.0/4.0.1/kext/crt3.o: Premature end of data, possibly corrupt file
--->  Scanning binaries for linking errors: 99.7%
Warning: Error parsing file /opt/local/lib/apple-gcc40/lib/gcc/i686-apple-darwin12.2.0/4.0.1/static/crt3.o: Premature end of data, possibly corrupt file
--->  Scanning binaries for linking errors: 100.0%

Here's a dump of the crt3.o file from the kext directory:

/opt/local/lib/apple-gcc40/lib/gcc/i686-apple-darwin12.2.0/4.0.1/kext
two:kext davidevans$ hexdump -C crt3.o
00000000  ce fa ed fe 07 00 00 00  03 00 00 00 01 00 00 00  |................|
00000010  01 00 00 00 7c 00 00 00  00 20 00 00 01 00 00 00  |....|.... ......|
00000020  7c 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  ||...............|
00000030  00 00 00 00 00 00 00 00  00 00 00 00 98 00 00 00  |................|
00000040  00 00 00 00 07 00 00 00  07 00 00 00 01 00 00 00  |................|
00000050  00 00 00 00 5f 5f 74 65  78 74 00 00 00 00 00 00  |....__text......|
00000060  00 00 00 00 5f 5f 54 45  58 54 00 00 00 00 00 00  |....__TEXT......|
00000070  00 00 00 00 00 00 00 00  00 00 00 00 98 00 00 00  |................|
00000080  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 80  |................|
*
00000090

This file does indeed seem to be a bit short, but is it correct?

If it is correct, should 'port' be complaining?

Change History (1)

comment:1 Changed 8 years ago by larryv (Lawrence Velázquez)

Keywords: rev-upgrade added
Resolution: duplicate
Status: newclosed

Duplicate of #36996. There’s nothing wrong with that file, port rev-upgrade is just misclassifying it as a Mach-O binary.

Note: See TracTickets for help on using tickets.