Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#39046 closed defect (invalid)

zsh-5.0.2 fails with clang

Reported by: Ionic (Mihai Moldovan) Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: haspatch Cc:
Port: zsh

Description

zsh is currently failing to compile with clang due to it working around a bug in Apple's GCC.

Don't use this workaround when compiling with clang. Patch attached.

Attachments (3)

zsh-portfile.diff (539 bytes) - added by Ionic (Mihai Moldovan) 6 years ago.
Add patch to zsh's Portfile.
patch-clang.diff (418 bytes) - added by Ionic (Mihai Moldovan) 6 years ago.
Don't use the workaround when compiling with clang.
main.log (174.1 KB) - added by Ionic (Mihai Moldovan) 6 years ago.
Not using +universal though, but same compiler.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by Ionic (Mihai Moldovan)

Attachment: zsh-portfile.diff added

Add patch to zsh's Portfile.

Changed 6 years ago by Ionic (Mihai Moldovan)

Attachment: patch-clang.diff added

Don't use the workaround when compiling with clang.

comment:1 Changed 6 years ago by Ionic (Mihai Moldovan)

comment:2 in reply to:  description Changed 6 years ago by larryv (Lawrence Velázquez)

Cc: larryv@… removed
Keywords: haspatch added
Owner: changed from macports-tickets@… to larryv@…
Status: newassigned

Replying to ionic@…:

zsh is currently failing to compile with clang due to it working around a bug in Apple's GCC.

I just rebuilt zsh @5.0.2+universal, using clang-425.0.28. Please attach a log of your build failure.

Changed 6 years ago by Ionic (Mihai Moldovan)

Attachment: main.log added

Not using +universal though, but same compiler.

comment:3 Changed 6 years ago by Ionic (Mihai Moldovan)

I can confirm zsh as such is building fine with clang, but not with ccache+clang.

It's ccache messing up the source fed into clang.

comment:4 in reply to:  3 Changed 6 years ago by larryv (Lawrence Velázquez)

Resolution: invalid
Status: assignedclosed

Cool. The patch is probably fine for upstream, but I don’t like patching/reinplace-ing/molesting the source more than is necessary.

comment:5 Changed 6 years ago by larryv (Lawrence Velázquez)

Note: See TracTickets for help on using tickets.