Opened 6 years ago

Closed 6 years ago

#39047 closed defect (fixed)

wireshark @1.8.6_1 +no_python: linking with liblua fails

Reported by: laughingtiger Owned by: opendarwin.org@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: hsivank@…, Veence (Vincent), mndavidoff (Monte Davidoff), vallon (Justin), cooljeanius (Eric Gallager), blair (Blair Zajac), com-macosforge@…, jovo@…, evandrix (Lee Wei Yeong), bill@…, jere@…, steven@…, ewen-naos-nz (Ewen McNeill), mrlamb@…, drkp (Dan Ports)
Port: wireshark

Description

After having deleted everything and done a complete clean reinstall of MacPorts and then first trying to install Wireshark, installation fails. This also failed with the same error when trying to install using previous MacPorts installation.

OS 10.8.3 X-Code 4.6.2

-->  Attempting to fetch wireshark-1.8.6.tar.bz2 from http://mse.uk.distfiles.macports.org/sites/distfiles.macports.org/wireshark
--->  Verifying checksum(s) for wireshark
--->  Extracting wireshark
--->  Applying patches to wireshark
--->  Configuring wireshark
Error: org.macports.configure for port wireshark returned: configure failure: command execution failed
Please see the log file for port wireshark for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wireshark/wireshark/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port wireshark failed

Attachments (3)

main.log (110.3 KB) - added by laughingtiger 6 years ago.
Wireshark install log
wireshark-macports.patch (33.9 KB) - added by hasso.tepper@… 6 years ago.
Portfile_wireshark.diff (854 bytes) - added by hsivank@… 6 years ago.

Download all attachments as: .zip

Change History (33)

Changed 6 years ago by laughingtiger

Attachment: main.log added

Wireshark install log

comment:1 Changed 6 years ago by laughingtiger

Cc: mllists@… added

Cc Me!

comment:2 Changed 6 years ago by mf2k (Frank Schima)

Cc: opendarwin.org@… mllists@… removed
Keywords: Wireshark install fails removed
Owner: changed from macports-tickets@… to opendarwin.org@…

The reporter is automatically Cc'ed.

Error is:

:info:configure checking for luaL_register in -llua... no
:info:configure checking for luaL_register in -llua5.1... no
:info:configure configure: error: Linking with liblua failed.

What is the output of the following?

port installed lua

comment:3 Changed 6 years ago by larryv (Lawrence Velázquez)

Cc: hsivank@… vince@… added

Maybe this has something to do with the recent lua version bump?

comment:4 Changed 6 years ago by larryv (Lawrence Velázquez)

Port: wireshark added; Wireshark removed
Summary: Wireshark-1.8.6 fails to installwireshark @1.8.6_1 +no_python: linking with liblua fails

comment:5 Changed 6 years ago by mf2k (Frank Schima)

I confirmed the problem is with the update to lua 5.2. It installs fine with lua 5.1.4.

$ port installed lua
The following ports are currently installed:
  lua @5.1.4_4 (active)
  lua @5.2.2_0

comment:6 in reply to:  2 Changed 6 years ago by laughingtiger

Replying to macsforever2000@…:

The reporter is automatically Cc'ed.

Error is:

:info:configure checking for luaL_register in -llua... no
:info:configure checking for luaL_register in -llua5.1... no
:info:configure configure: error: Linking with liblua failed.

What is the output of the following?

port installed lua

output is...

port installed lua
The following ports are currently installed:
  lua @5.2.2_0 (active)

comment:7 Changed 6 years ago by mndavidoff (Monte Davidoff)

Cc: md14-macports@… added

Cc Me!

comment:8 Changed 6 years ago by hsivank@…

Build is ok with wireshark-devel(1.9.0) and lua@5.2
I found a patch for 1.8.X branch http://www.openmamba.org/showfile.html?file=/pub/openmamba/devel/patches/wireshark-1.8.2-lua-5.2-2.patch (not tested)
Maybe it is time to update wireshark port to version 1.9.x and wireshark-devel to version 1.10.x ?

comment:9 Changed 6 years ago by vallon (Justin)

Cc: JustinVallon@… added

Cc Me!

comment:10 in reply to:  8 Changed 6 years ago by ghosthound

Replying to hsivank@…:

Build is ok with wireshark-devel(1.9.0) and lua@5.2
I found a patch for 1.8.X branch http://www.openmamba.org/showfile.html?file=/pub/openmamba/devel/patches/wireshark-1.8.2-lua-5.2-2.patch (not tested)
Maybe it is time to update wireshark port to version 1.9.x and wireshark-devel to version 1.10.x ?

The 1.9 branch of wireshark is the development branch for 1.10, aka not a stable/release branch, thus I don't think wireshark should go to 1.9, it should go to 1.10 when 1.10 is released/stable.

comment:11 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:12 Changed 6 years ago by blair (Blair Zajac)

Cc: blair@… added

Cc Me!

comment:13 Changed 6 years ago by com-macosforge@…

Cc: com-macosforge@… added

Cc Me!

comment:14 Changed 6 years ago by jovo@…

Cc: jovo@… added

Cc Me!

comment:15 Changed 6 years ago by evandrix (Lee Wei Yeong)

Cc: evandrix@… added

Cc Me!

comment:16 Changed 6 years ago by bill@…

Cc: bill@… added

Cc Me!

comment:17 Changed 6 years ago by jere@…

Cc: jere@… added

Cc Me!

comment:18 Changed 6 years ago by hasso.tepper@…

The patch attached to the comment #10 is obviously correct. I can also confirm (tested not in macports though) that it solves the problem with lua 5.2.

Edit: OK, I was informed that it's not enough - you need to backport some more - https://anonsvn.wireshark.org/viewvc?view=revision&revision=43479 .

Last edited 6 years ago by hasso.tepper@… (previous) (diff)

comment:19 in reply to:  18 Changed 6 years ago by breiter (Brian Reiter)

Replying to hasso.tepper@…:

The patch attached to the comment #10 is obviously correct. I can also confirm (tested not in macports though) that it solves the problem with lua 5.2.

Edit: OK, I was informed that it's not enough - you need to backport some more - https://anonsvn.wireshark.org/viewvc?view=revision&revision=43479 .

Yes. It's not enough to bang on the ./configure script. The LUA embedding API changed and the code will not compile against LUA5.2 without patching.

https://bugs.wireshark.org/bugzilla/attachment.cgi?bugid=7400&action=viewall

Last edited 6 years ago by breiter (Brian Reiter) (previous) (diff)

comment:20 Changed 6 years ago by steven@…

Cc: steven@… added

Cc Me!

comment:21 Changed 6 years ago by ewen-naos-nz (Ewen McNeill)

Cc: macports@… added

Cc Me!

comment:22 Changed 6 years ago by ewen-naos-nz (Ewen McNeill)

According to Wireshark Bug 7400 (mentioned here at comment 19) the patches were committed in February 2013, and scheduled for backport to Wireshark 1.8. I see that there is are new release files as of 17 May 2013, including a Wireshark 1.8.7 (MacPorts has Wireshark 1.8.6). It seems likely those would include the Lua API change fixes. So the most expedient resolution to this problem might be to upgrade to Wireshark 1.8.7, rather than re-backporting the Lua 5.2 compatibility patches. (For now I've downgraded lua on my host to 5.1, since IIRC I don't use it for much other than Wireshark.)

Ewen

comment:23 Changed 6 years ago by schnide (Joe Schnide)

I was able to find a workaround to get wireshark installed thanks to # 39291

port uninstall wireshark

port clean --all wireshark

port install wireshark +no_lua

Changed 6 years ago by hasso.tepper@…

Attachment: wireshark-macports.patch added

comment:24 Changed 6 years ago by hasso.tepper@…

The wireshark-macports.patch upgrades wireshark to 1.8.7 and integrates http://www.openmamba.org/showfile.html?file=/pub/openmamba/devel/patches/wireshark-1.8.2-lua-5.2-[1-3].patch patches to build it with lua 5.2.

comment:25 in reply to:  22 Changed 6 years ago by ghosthound

Replying to macports@…:

According to Wireshark Bug 7400 (mentioned here at comment 19) the patches were committed in February 2013, and scheduled for backport to Wireshark 1.8. I see that there is are new release files as of 17 May 2013, including a Wireshark 1.8.7 (MacPorts has Wireshark 1.8.6). It seems likely those would include the Lua API change fixes. So the most expedient resolution to this problem might be to upgrade to Wireshark 1.8.7, rather than re-backporting the Lua 5.2 compatibility patches. (For now I've downgraded lua on my host to 5.1, since IIRC I don't use it for much other than Wireshark.)

Ewen

Unfortunately 1.8.7 does not include the lua 5.2 fixes.

comment:26 in reply to:  24 Changed 6 years ago by ghosthound

Replying to hasso.tepper@…:

The wireshark-macports.patch upgrades wireshark to 1.8.7 and integrates http://www.openmamba.org/showfile.html?file=/pub/openmamba/devel/patches/wireshark-1.8.2-lua-5.2-[1-3].patch patches to build it with lua 5.2.

Thanks, I'll check this out, I haven't finished integrating the wireshark/lua5.2 patches yet.

comment:27 Changed 6 years ago by larryv (Lawrence Velázquez)

Cc: mrlamb@… added

Has duplicate #39335.

comment:28 Changed 6 years ago by hsivank@…

Wireshark 1.10.0 has been released and is now considered as the stable branch. (attached a patch to update the port)

Changed 6 years ago by hsivank@…

Attachment: Portfile_wireshark.diff added

comment:29 Changed 6 years ago by drkp (Dan Ports)

Cc: dports@… added

Cc Me!

comment:30 Changed 6 years ago by ghosthound

Resolution: fixed
Status: newclosed

resolved in r106712 by updating to 1.10.1

Note: See TracTickets for help on using tickets.