Opened 6 years ago

Closed 22 months ago

#39151 closed defect (fixed)

cflow 1.0 Build error with clang

Reported by: matt.a.olson@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: jfilippidis@…, kurthindenburg (Kurt Hindenburg)
Port: cflow

Description

Using mountain lion with Xcode version 4.6.2, cflow fails to build using default compiler clang. The package could be built with

sudo port install cflow configure.compiler=llvm-gcc-4.2

Attachments (1)

main.log (37.1 KB) - added by matt.a.olson@… 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by matt.a.olson@…

Attachment: main.log added

comment:1 Changed 6 years ago by jfilippidis@…

Cc: jfilippidis@… added

Cc Me!

comment:2 Changed 6 years ago by jfilippidis@…

Same issue here with 10.8.4 and Xcode 4.5, managed to compile and install with the proposed command. Thanks for the suggestion.

comment:3 Changed 6 years ago by larryv (Lawrence Velázquez)

Cc: gnn@… removed
Owner: changed from macports-tickets@… to gnn@…

comment:4 Changed 6 years ago by jfilippidis@…

The current cflow Portfile has an outdated version (1.0), whereas the current one is 1.4 and its installation does not suffer from this issue. See 39824.

comment:5 Changed 2 years ago by l2dy (Zero King)

Owner: changed from gnn@… to macports-tickets@…
Status: newassigned

comment:6 Changed 22 months ago by kurthindenburg (Kurt Hindenburg)

Cc: kurthindenburg added
Resolution: fixed
Status: assignedclosed

macports version is 1.5 - this issue should be fixed.

Note: See TracTickets for help on using tickets.