Opened 10 years ago

Closed 6 weeks ago

#39307 closed defect (fixed)

mplayer no subtitles, no fonts

Reported by: markurujapan@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: cooljeanius (Eric Gallager), jchauvel@…, jtshs256@…
Port: mplayer

Description

Hello, I installed mplayer with macports, and when I try to watch a movie, I can't see any subtitle :(, no osd etc

Any solution?

Thanks

Change History (10)

comment:1 Changed 10 years ago by cooljeanius (Eric Gallager)

Which variants do you have mplayer installed with? Type port installed mplayer to find out, and then post the results here.

Edit: +osd is a variant. You can also use the +fribidi variant to drag in the +osd variant as well.

Last edited 10 years ago by cooljeanius (Eric Gallager) (previous) (diff)

comment:2 Changed 10 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to jeremyhu@…
Port: mplayer added

In the future, please fill in the Port field and Cc the port maintainer(s).

comment:3 Changed 10 years ago by markurujapan@…

with mplayer2, all perfect

port installed mplayer2
The following ports are currently installed:
  mplayer2 @2.0-20130428_0 (active)

The issue is only if I install mplayer 1

Last edited 9 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:4 Changed 9 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

If you're still experiencing this problem, could you please answer Eric's question from 6 months ago:

Which variants do you have mplayer installed with? Type port installed mplayer to find out, and then post the results here.

comment:6 Changed 9 years ago by jchauvel@…

Cc: jchauvel@… added

Cc Me!

comment:7 Changed 9 years ago by jtshs256@…

Cc: jtshs256@… added

Cc Me!

comment:8 Changed 9 years ago by coredumb@…

mplayer seek freetype header files in /opt/local/include/freetype, but the newest freetype port put the header files in /opt/local/include/freetype2. solve the problem by adding '-I${prefix}/include/freetype2' in --extra-cflags argument

comment:9 Changed 9 years ago by machsna (J. ‘mach’ Wust)

@coredumb: Many thanks for the hint – with your help, I have now been able to manually fix the issue by doing the following (unfortunately, I am ignorant of --extra-cflags):

ln -s /opt/local/include/freetype2 /opt/local/include/freetype

Of course, I hope this will not mess up too much of macports.

comment:10 Changed 6 weeks ago by kencu (Ken)

Resolution: fixed
Status: newclosed

mplayer has been updated.

https://github.com/macports/macports-ports/commit/d6e3444351d9e5844a9736c3ac4d0f991a66b920

please reopen with new information if this is still an issue for yoy

Note: See TracTickets for help on using tickets.