Opened 4 years ago

Closed 4 years ago

#39335 closed defect (duplicate)

wireshark 1.8.6_2 - upgrade failed

Reported by: mrlamb@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc:
Port: wireshark

Description

Failed to upgrade wireshark from 1.8.6_1 to 1.8.6_2 do to error linking with liblua. This occurred during routine: port selfupdate; port upgrade outdated.

Note the following error line in the log file fragment listed below: :info:configure configure: error: Linking with liblua failed.

Command Line:

$ port outdated
The following installed ports are outdated:
wireshark                      1.8.6_1 < 1.8.6_2
$ sudo port -uc upgrade outdated
--->  Computing dependencies for wireshark
--->  Fetching archive for wireshark
--->  Attempting to fetch wireshark-1.8.6_2+no_python.darwin_12.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/wireshark
--->  Attempting to fetch wireshark-1.8.6_2+no_python.darwin_12.x86_64.tbz2 from http://packages.macports.org/wireshark
--->  Attempting to fetch wireshark-1.8.6_2+no_python.darwin_12.x86_64.tbz2 from http://lil.fr.packages.macports.org/wireshark
--->  Fetching distfiles for wireshark
--->  Attempting to fetch wireshark-1.8.6.tar.bz2 from http://www.wireshark.org/download/src/
--->  Attempting to fetch wireshark-1.8.6.tar.bz2 from http://www.wireshark.org/download/src/all-versions/
--->  Verifying checksum(s) for wireshark
--->  Extracting wireshark
--->  Applying patches to wireshark
--->  Configuring wireshark
Error: org.macports.configure for port wireshark returned: configure failure: command execution failed
Please see the log file for port wireshark for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wireshark/wireshark/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
$ tail -n15 /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wireshark/wireshark/main.log
:info:configure checking lauxlib.h presence... yes
:info:configure checking for lauxlib.h... yes
:info:configure checking for luaL_register in -llua... no
:info:configure checking for luaL_register in -llua5.1... no
:info:configure configure: error: Linking with liblua failed.
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wireshark/wireshark/work/wireshark-1.8.6" && ./configure --prefix=/opt/local --with-libsmi=/opt/local --disable-usr-local --with-adns=/opt/local --without-c-ares --with-geoip=/opt/local --with-gnutls=yes --with-libgcrypt-prefix=/opt/local --with-lua=/opt/local --enable-ipv6 --with-pcap=/opt/local --with-ssl=/opt/local --with-zlib=/opt/local --mandir=\${prefix}/share/man --infodir=\${prefix}/share/info --with-portaudio=/opt/local --disable-warnings-as-errors --with-krb5=/opt/local --without-python
:info:configure Exit code: 1
:error:configure org.macports.configure for port wireshark returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
    while executing
"$procedure $targetname"
:info:configure Warning: targets not executed for wireshark: org.macports.install org.macports.configure org.macports.build org.macports.destroot
:notice:configure Please see the log file for port wireshark for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_wireshark/wireshark/main.log

Attachments (1)

main.log.gz (4.7 KB) - added by mrlamb@… 4 years ago.
wireshark up

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by mrlamb@…

wireshark up

comment:1 Changed 4 years ago by mrlamb@…

  • Cc mrlamb@… added

Cc Me!

comment:2 Changed 4 years ago by larryv (Lawrence Velázquez)

  • Cc mrlamb@… removed
  • Keywords wireshark liblua lua removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #39047.

Note: See TracTickets for help on using tickets.