Opened 8 years ago

Closed 8 years ago

#39343 closed defect (duplicate)

R compiling error on 10.6.8

Reported by: gregbg@… Owned by: kjellpk (Kjell Konis)
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: cooljeanius (Eric Gallager)
Port: R

Description

Hello,

R package fails to compile while upgrading, see log attached.

Attachments (2)

R.log (35.4 KB) - added by gregbg@… 8 years ago.
an attempt of upgrading R
R.full.log (173.5 KB) - added by gregbg@… 8 years ago.
full log

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by gregbg@…

Attachment: R.log added

an attempt of upgrading R

comment:1 Changed 8 years ago by volcdavis@…

I wonder if this is the same as https://trac.macports.org/ticket/38958. It appears to be failing at the same place. I don't think there was a solution beyond changing the variant to +gcc47.

comment:2 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:3 Changed 8 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to kjell.konis@…
Port: R added

In the future, please fill in the Port field and Cc the port maintainer(s).

Your log is not complete, please clean and try again and attach the complete main.log if it fails again.

Changed 8 years ago by gregbg@…

Attachment: R.full.log added

full log

comment:4 in reply to:  1 Changed 8 years ago by gregbg@…

Replying to volcdavis@…:

I wonder if this is the same as https://trac.macports.org/ticket/38958. It appears to be failing at the same place. I don't think there was a solution beyond changing the variant to +gcc47.

I confirm that compiling with +gcc47 works - is it clear why other gcc versions didn't work?

comment:5 Changed 8 years ago by larryv (Lawrence Velázquez)

Resolution: duplicate
Status: newclosed

Duplicate of #38958.

Note: See TracTickets for help on using tickets.