Opened 8 years ago

Closed 7 years ago

#39430 closed defect (fixed)

deluge @1.3.6 +python27: deluge-gtk-2.7 fails to start with "import error"

Reported by: bitmail@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: deluge

Description

System: OSX 10.5.8, PPC, Macports 2.1.3 fully updated.

Installation of Deluge @1.3.6 +python2.7 works fine.

However starting the GTK interface fails:

deluge-gtk-2.7 Traceback (most recent call last):
  File "/opt/local/bin/deluge-gtk-2.7", line 9, in <module>
    load_entry_point('deluge==1.3.6', 'gui_scripts', 'deluge-gtk')()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 115, in start
    Gtk().start()
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 112, in start
    GtkUI(self.args)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/deluge/ui/gtkui/gtkui.py", line 201, in __init__
    import gtk_osxapplication
ImportError: No module named gtk_osxapplication

Previous versions (f.e. 1.3.5) worked fine. I didn't use it in a while, so I don't know exactly when it broke and if it's due to the update to 1.3.6 or some dependency. I did uninstall deluge and reinstall it, to no avail.

Change History (7)

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Cc: devans@… removed
Owner: changed from macports-tickets@… to devans@…

comment:2 Changed 8 years ago by dbevans (David B. Evans)

Status: newassigned

comment:3 Changed 8 years ago by dbevans (David B. Evans)

Code at the point of failure is this:

        if deluge.common.osx_check() and gtk.gdk.WINDOWING == "quartz":
            import gtk_osxapplication

so I assume that you have gtk2 +quartz installed (please confirm). Looks like a missing dependency in this case. Works well for me with gtk2 +x11 installed.

comment:4 Changed 8 years ago by bitmail@…

Yes, I use gtk2 +quartz. It did work well since 1.3.3 (or 1.3.2, I'm not sure), but some recent upgrade broke it.

Edit:

shell$ port installed | egrep "py27|gtk|deluge|rasterbar"
  deluge @1.3.6_0+python27 (active)
  gtk-doc @1.18_0+python27 (active)
  gtk-engines2 @2.20.2_2 (active)
  gtk-osx-application @2.0.1_0+python27 (active)
  gtk2 @2.24.18_1+no_x11+quartz (active)
  libtorrent-rasterbar @0.16.10_0+python27 (active)
  py27-beaker @1.6.4_0 (active)
  py27-cairo @1.10.0_2 (active)
  py27-chardet @2.0.1_0 (active)
  py27-distribute @0.6.45_0
  py27-game @1.9.1_6 (active)
  py27-gobject @2.28.6_0 (active)
  py27-gtk @2.22.0_3+x11
  py27-libxml2 @2.9.0_0 (active)
  py27-mako @0.8.1_0 (active)
  py27-markupsafe @0.18_0 (active)
  py27-nose @1.2.1_1 (active)
  py27-numeric @24.2_2 (active)
  py27-numpy @1.7.1_0 (active)
  py27-openssl @0.13_0 (active)
  py27-py @1.4.14_0 (active)
  py27-pygtk @2.24.0_1
  py27-pygtk @2.24.0_1+quartz (active)
  py27-pytest @2.3.4_0 (active)
  py27-setuptools @0.7.2_0 (active)
  py27-twisted @12.0.0_0 (active)
  py27-twisted-web2 @8.1.0_0 (active)
  py27-xdg @0.25_0 (active)
  py27-zopeinterface @3.8.0_1 (active)

Prime suspects (imho!) are py27-gtk > py27-pygtk and py27-distribute > py27-setuptools.

Last edited 8 years ago by bitmail@… (previous) (diff)

comment:5 Changed 8 years ago by dbevans (David B. Evans)

In fact, it appears that the problem is with deluge 1.3.6 itself.

In this version, code was added to attempt to add OS X Native style menus (in the OS X menu bar) as opposed to GTK+ style menus (in the app window) when it detects that GTK+ is installed with the quartz backend.

This normally would require an additional dependency on the current OS X integration library (port gtk-osx-application) but it appears that they used an older deprecated API (port ige-mac-integration) which currently does not build properly on MacPorts and is not API compatible with the more current library.

This only has impact for +quartz users such as yourself.

So rather than hold things up any further, I am disabling this code for now, while I coordinate with the upstream folks about this.

Fix committed in r107048. Let me know if this works as you expect.

Thanks for your report.

comment:6 Changed 8 years ago by bitmail@…

Hello,

just tested your patch (selfupdate & upgrade outdated) and 1.3.6_1 seems to work fine. Thanks for fixing it that quickly! Do you think upstream will resolve the issue in a timely fashion as well?

comment:7 Changed 7 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: assignedclosed
Version: 2.1.3
Note: See TracTickets for help on using tickets.