New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #39467 (new defect)

Opened 2 years ago

Last modified 2 years ago

rb-capistrano does not install capistrano in any useful form

Reported by: grail@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: kimuraw@…
Port: rb-capistrano

Description

Upon installing rb-capistrano, the capistrano gem is installed in /opt/local/lib/ruby/gems/gems/capistrano-2.5.3, capify-1.8 is present but there is no symlink for capify.

Thus even if capify-1.8 is invoked directly, the gem cannot be found. Installing capistrano manually using /opt/local/bin/gem will result in teh capistrano gem being installed to /opt/local/lib/ruby/gems/1.8/gems/capistrano-2.15.4, with capify in /opt/local/bin.

Change History

comment:1 Changed 2 years ago by larryv@…

  • Cc kimuraw@… added
  • Port set to rb-capistrano

comment:2 Changed 2 years ago by egall@…

This is probably due to the changes introduced with ruby_select...

Note: See TracTickets for help on using tickets.