Opened 16 years ago

Closed 16 years ago

#3954 closed defect (duplicate)

ettercap-ng still doesn't build correctly

Reported by: unlucio@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

I've already read bug #3031 and this is what happened =((

All those fix and patches are missing in the port tree =((( so this still doesn't work =((

the port version is still 0.7.1 (instead of 0.7.3(

patching the Portfile doesn't help anyway (I'm actually not really confident with the port sys)

--> this is what appens <-- DEBUG: Found port in file:///opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/ettercap-ng DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/ettercap-ng DEBUG: Requested variant powerpc is not provided by port ettercap-ng. DEBUG: Requested variant darwin is not provided by port ettercap-ng. DEBUG: Requested variant macosx is not provided by port ettercap-ng. Portfile changed since last build; discarding previous state. DEBUG: Found port in file:///opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/devel/openssl DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/devel/openssl DEBUG: Searching for dependency: openssl DEBUG: Found Dependency: receipt exists for openssl DEBUG: Found port in file:///opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/libpcap DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/libpcap DEBUG: Searching for dependency: libpcap DEBUG: Found Dependency: receipt exists for libpcap DEBUG: Found port in file:///opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/libnet11 DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/net/libnet11 DEBUG: Searching for dependency: libnet11 DEBUG: Found Dependency: receipt exists for libnet11 DEBUG: Found port in file:///opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/devel/pcre DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/ rsync.rsync.opendarwin.org_dpupdate_dports/devel/pcre DEBUG: Searching for dependency: pcre DEBUG: Found Dependency: receipt exists for pcre DEBUG: Executing com.apple.main (ettercap-ng) DEBUG: No TGZ archive: /opt/local/var/db/dports/packages/darwin/powerpc/ettercap- ng-0.7.3_0.powerpc.tgz DEBUG: Skipping unarchive (ettercap-ng) since no archive found DEBUG: Skipping completed com.apple.unarchive (ettercap-ng) ---> Fetching ettercap-ng DEBUG: Executing com.apple.fetch (ettercap-ng) ---> patch-configure doesn't seem to exist in /opt/local/var/db/dports/distfiles/ettercap-ng ---> Attempting to fetch patch-configure from http://distfiles-od.opendarwin.org/ DEBUG: Assembled command: 'cd "/opt/local/var/db/dports/distfiles/ettercap-ng" && /usr/bin/curl -f -L -o patch-configure.TMP http://distfiles-od.opendarwin.org/patch-configure'

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0

curl: (22) The requested URL returned error: 404 ---> Attempting to fetch patch-configure from http://distfiles-msn.opendarwin.org/ DEBUG: Assembled command: 'cd "/opt/local/var/db/dports/distfiles/ettercap-ng" && /usr/bin/curl -f -L -o patch-configure.TMP http://distfiles-msn.opendarwin.org/patch-configure'

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0

curl: (22) The requested URL returned error: 404 ---> Attempting to fetch patch-configure from http://distfiles-bay13.opendarwin.org/ DEBUG: Assembled command: 'cd "/opt/local/var/db/dports/distfiles/ettercap-ng" && /usr/bin/curl -f -L -o patch-configure.TMP http://distfiles-bay13.opendarwin.org/patch-configure'

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0

curl: (22) The requested URL returned error: 404 Error: Target com.apple.fetch returned: fetch failed Warning: the following items did not execute (for ettercap-ng): com.apple.activate com.apple.fetch com.apple.extract com.apple.checksum com.apple.patch com.apple.configure com.apple.build com.apple.destroot com.apple.archive com.apple.install

--> end <--

please help!!! =)))

Change History (1)

comment:1 Changed 16 years ago by blb@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 3031 *

Note: See TracTickets for help on using tickets.