Opened 4 years ago

Closed 4 years ago

#39589 closed defect (fixed)

cgminer @3.2.2 - build failure when nawk is active

Reported by: havier25099amph@… Owned by: skymoo (Adam Mercer)
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc:
Port: cgminer

Description (last modified by ryandesign (Ryan Schmidt))

cgminer fails to build.

Error is:

--->  Computing dependencies for cgminer
--->  Configuring cgminer
Error: org.macports.configure for port cgminer returned: configure failure: command execution failed
Please see the log file for port cgminer for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_finance_cgminer/cgminer/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port cgminer failed

I have attached the full error log

Environment:

Darwin abner.sadie 12.4.0 Darwin Kernel Version 12.4.0: Wed May 1 17:57:12 PDT 2013; root:xnu-2050.24.15~1/RELEASE_X86_64 x86_64 i386 MacBookPro5,4 Darwin

Xcode 4.6.2 Build version 4H1003

Thanks!

Attachments (1)

main.log (25.7 KB) - added by havier25099amph@… 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by havier25099amph@…

comment:1 Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Description modified (diff)
  • Keywords bitcoin removed
  • Milestone MacPorts 2.2.0 deleted
  • Owner changed from macports-tickets@… to ram@…
  • Port @3.2.2 removed

The log says:

:info:configure nawk: illegal jump type 339
:info:configure  input record number 16, file
:info:configure  source line number 306

We've seen this problem several times before with other ports. The problem is that you have the nawk port installed, and cgminer tries to find an awk implementation for its configuration, and decides to use nawk, but nawk is not compatible with what the configuration wants to do. If you temporarily deactivate the nawk port, then you should be able to build cgminer. You can re-activate nawk later if you want.

sudo port clean cgminer
sudo port -f deactivate nawk
sudo port install cgminer
sudo port activate nawk

In other ports we've used the conflicts_build portgroup to handle this conflict. Perhaps this could be added to this port as well.

comment:2 Changed 4 years ago by ryandesign (Ryan Schmidt)

  • Summary changed from cgminer @3.2.2 - build failure to cgminer @3.2.2 - build failure when nawk is active

comment:3 Changed 4 years ago by skymoo (Adam Mercer)

  • Status changed from new to assigned

Interesting, I can't reproduce this when using nawk:

checking build system type... x86_64-apple-darwin12.4.0
checking host system type... x86_64-apple-darwin12.4.0
checking target system type... x86_64-apple-darwin12.4.0
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /opt/local/bin/gmkdir -p
checking for gawk... no
checking for mawk... no
checking for nawk... nawk

<snip>

checking for pkg-config... /opt/local/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for LIBCURL... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating compat/Makefile
config.status: creating compat/jansson/Makefile
config.status: creating ccan/Makefile
config.status: creating lib/Makefile
config.status: creating config.h
config.status: executing depfiles commands



------------------------------------------------------------------------
cgminer 3.2.2
------------------------------------------------------------------------


Configuration Options Summary:

  curses.TUI...........: FOUND: -lncurses
  OpenCL...............: FOUND. GPU mining support enabled
  scrypt...............: Disabled
  ADL..................: SDK NOT found, GPU monitoring support DISABLED

  Avalon.ASICs.........: Disabled
  BFL.ASICs............: Disabled
  BitForce.FPGAs.......: Disabled
  Icarus.FPGAs.........: Disabled
  ModMiner.FPGAs.......: Disabled
  Ztex.FPGAs...........: Disabled

Compilation............: make (or gmake)
  CPPFLAGS.............: -I/opt/local/include
  CFLAGS...............: -pipe -Os -arch x86_64
  LDFLAGS..............: -L/opt/local/lib -Wl,-headerpad_max_install_names -arch x86_64
  LDADD................:  -L/opt/local/lib -lcurl  -ljansson -lpthread -framework OpenCL    -lm

Installation...........: make install (as root if needed, with 'su' or 'sudo')
  prefix...............: /opt/local

We both seem to be using the Mountain Lion with the latest Xcode, so this is a strange one...

Can you confirm that deactivating nawk allows you to build?

comment:4 follow-up: Changed 4 years ago by cooljeanius (Eric Gallager)

Also if you install gawk, the configure script will pick that up first and use that instead of nawk. Also gawk is the best of the awks so you should probably install it anyways.

comment:5 in reply to: ↑ 4 Changed 4 years ago by skymoo (Adam Mercer)

Replying to egall@…:

Also if you install gawk, the configure script will pick that up first and use that instead of nawk. Also gawk is the best of the awks so you should probably install it anyways.

So another solution could be to add gawk to depends_build

comment:6 Changed 4 years ago by havier25099amph@…

I tried the gawk solution and it worked. Thanks, everyone!

hostname:~ user$ sudo port install gawk
Password:
--->  Computing dependencies for gawk
--->  Fetching archive for gawk
--->  Attempting to fetch gawk-4.0.2_0.darwin_12.x86_64.tbz2 from http://packages.macports.org/gawk
--->  Attempting to fetch gawk-4.0.2_0.darwin_12.x86_64.tbz2.rmd160 from http://packages.macports.org/gawk
--->  Installing gawk @4.0.2_0
--->  Activating gawk @4.0.2_0
--->  Cleaning gawk
--->  Updating database of binaries: 100.0%
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.
hostname:~ user $ sudo port install cgminer
--->  Computing dependencies for cgminer
--->  Configuring cgminer
--->  Building cgminer
--->  Staging cgminer into destroot
--->  Installing cgminer @3.2.2_0
--->  Activating cgminer @3.2.2_0
--->  Cleaning cgminer
--->  Updating database of binaries: 100.0%
--->  Scanning binaries for linking errors: 100.0%
--->  No broken files found.

comment:7 Changed 4 years ago by skymoo (Adam Mercer)

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.