Opened 7 years ago

Closed 21 months ago

#39660 closed request (wontfix)

emulators/virtualbox41 - New Port Because VirtualBox 4.2.16 Cannot Boot OS X VMs

Reported by: rmstonecipher@… Owned by: royliu@…
Priority: Normal Milestone:
Component: ports Version: 2.1.3
Keywords: Cc: cooljeanius (Eric Gallager)
Port: virtualbox41

Description

Please refer to upstream tickets linked in https://www.virtualbox.org/ticket/11490.
In that and other upstream tickets users recommended using VirtualBox 4.1 for OS X VMs on OS X hosts.
I would propose creating a virtualbox41 port but do not understand the various patches in the current virtualbox port well enough to modify them to suit VirtualBox 4.1.
This port may conflict with the virtualbox port since both require kernel modules.
The current 4.1 series release of VirtualBox is 4.1.26.

Change History (4)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

This was supposed to have been fixed in VirtualBox 4.3, so we should just update the port to that version.

comment:2 Changed 6 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:3 Changed 21 months ago by chrstphrchvz (Christopher Chavez)

4.1 is long unsupported, so it really is not ideal to create a virtualbox41 port. I think this ticket should either be rephrased as a bug for the virtualbox port, or just merged into/closed as duplicate of #50622 which is trying to get 5.1.x or later working.

comment:4 Changed 21 months ago by mf2k (Frank Schima)

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.