Opened 8 years ago

Closed 8 years ago

#39717 closed update (fixed)

Update goffice @0.8.17 to 0.10.3 with 0.8.17 subport

Reported by: c.herbig@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc: ryandesign (Ryan Schmidt)
Port: goffice

Description

This patch allows gnucash to still function requiring goffice 0.8.x, while also allowing gnumeric to be updated to the 1.12.x series, and also allows gnome-chemistry-utils to be installed. The 0.8.17 subport still needs the patchfiles directory that is already there.

Attachments (1)

Portfile-goffice.diff (2.1 KB) - added by c.herbig@… 8 years ago.
brings goffice up to newly released 0.10.4

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by c.herbig@…

Sorry, I can't seem to add haspatch once it was submitted.

comment:2 Changed 8 years ago by larryv (Lawrence Velázquez)

Keywords: haspatch added

comment:3 Changed 8 years ago by c.herbig@…

The gnumeric team has updated goffice to 0.10.4, but the files for the new gnumeric and goffice aren't available yet, hence why this is still pointing to 0.10.3.

comment:4 Changed 8 years ago by mf2k (Frank Schima)

[deleted duplicate post]

Last edited 8 years ago by mf2k (Frank Schima) (previous) (diff)

comment:4 Changed 8 years ago by mf2k (Frank Schima)

The epoch cannot be removed from the goffice port or else no one will see the update. Also, the epoch and revision should be removed from the goffice-08 sub-port.

comment:5 in reply to:  4 ; Changed 8 years ago by c.herbig@…

Replying to macsforever2000@…:

The epoch cannot be removed from the goffice port or else no one will see the update. Also, the epoch and revision should be removed from the goffice-08 sub-port.

Ok, fixed. I re-read the documentation, and I think I understand it this time. For example, the only time epoch could be removed is if the version went from 0.10.x -> 1.0.0, is that correct?

comment:6 in reply to:  5 ; Changed 8 years ago by larryv (Lawrence Velázquez)

Replying to c.herbig@…:

Ok, fixed. I re-read the documentation, and I think I understand it this time. For example, the only time epoch could be removed is if the version went from 0.10.x -> 1.0.0, is that correct?

A port’s epoch can never be removed or decreased, ever.

Think of a port’s real version as [epoch].[version].[revision]. A port at 1.x.y will always be considered newer than a port at 0.m.n. Removing a port’s epoch is equivalent to setting it to 0, so no one would ever see that update.

comment:7 in reply to:  6 Changed 8 years ago by c.herbig@…

Replying to larryv@…:

Replying to c.herbig@…:

Ok, fixed. I re-read the documentation, and I think I understand it this time. For example, the only time epoch could be removed is if the version went from 0.10.x -> 1.0.0, is that correct?

A port’s epoch can never be removed or decreased, ever.

Think of a port’s real version as [epoch].[version].[revision]. A port at 1.x.y will always be considered newer than a port at 0.m.n. Removing a port’s epoch is equivalent to setting it to 0, so no one would ever see that update.

Ah, both of those make more sense now. Thank you.

comment:8 Changed 8 years ago by c.herbig@…

I tidied up the subport section. It seems to work fine, and should be less maintenance.

Changed 8 years ago by c.herbig@…

Attachment: Portfile-goffice.diff added

brings goffice up to newly released 0.10.4

comment:9 Changed 8 years ago by drkp (Dan Ports)

Cc: dports@… removed
Owner: changed from macports-tickets@… to dports@…
Status: newassigned

comment:10 Changed 8 years ago by drkp (Dan Ports)

Resolution: fixed
Status: assignedclosed

Thanks, committed in r108288. I renamed the subport to goffice08 to be in line with other port names, and added a deactivate hack to prevent conflicts when upgrading.

Note: See TracTickets for help on using tickets.