Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#39882 closed defect (duplicate)

Error: Processing of port webkit-gtk failed — at Version 5

Reported by: iskaspb@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc:
Port: webkit-gtk

Description (last modified by larryv (Lawrence Velázquez))

After reinstallation of MacPorts still see error during "port install webkit-gtk":

...
--->  Fetching distfiles for webkit-gtk
--->  Attempting to fetch webkitgtk-2.0.4.tar.xz from http://jog.id.distfiles.macports.org/macports/mpdistfiles/webkit-gtk
--->  Verifying checksums for webkit-gtk
--->  Extracting webkit-gtk
--->  Applying patches to webkit-gtk
--->  Configuring webkit-gtk
--->  Building webkit-gtk
Error: org.macports.build for port webkit-gtk returned: command execution failed
Please see the log file for port webkit-gtk for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk/webkit-gtk/main.log

webkit-gtk/main.log I see link error:

...
:info:build g-ir-scanner: link: /bin/sh ./libtool --mode=link --tag=CC /usr/bin/clang -arch x86_64 -o /opt/local/var/macports/build/_opt_local_v
ar_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk/webkit-gtk/work/webkitgtk-2.0.4/tmp-introspectucfajD/WebKit-1.0 -ex
port-dynamic /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk/webkit-gtk/w
ork/webkitgtk-2.0.4/tmp-introspectucfajD/WebKit-1.0.o -L. -lwebkitgtk-1.0 -ljavascriptcoregtk-1.0 -L/opt/local/lib -lgmodule-2.0 -lgtk-x11-2.0 -
lgdk-x11-2.0 -lpangocairo-1.0 -lgio-2.0 -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lXfixes -lX11 -lXext -latk-1.0 -lca
iro -lgdk_pixbuf-2.0 -lpangoft2-1.0 -lpango-1.0 -lm -lfreetype -lfontconfig -lsoup-2.4 -lgio-2.0 -lgobject-2.0 -lglib-2.0 -lintl
:info:build libtool: link: /usr/bin/clang -arch x86_64 -o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_relea
se_tarballs_ports_www_webkit-gtk/webkit-gtk/work/webkitgtk-2.0.4/tmp-introspectucfajD/.libs/WebKit-1.0 /opt/local/var/macports/build/_opt_local_
var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk/webkit-gtk/work/webkitgtk-2.0.4/tmp-introspectucfajD/WebKit-1.0.o 
 -L. /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk/webkit-gtk/work/webk
itgtk-2.0.4/.libs/libwebkitgtk-1.0.dylib -L/opt/local/lib /opt/local/lib/libenchant.dylib /opt/local/lib/libharfbuzz-icu.dylib /opt/local/lib/li
bgailutil.dylib /opt/local/lib/libgeoclue.dylib /opt/local/lib/libdbus-glib-1.dylib /opt/local/lib/libdbus-1.dylib /opt/local/lib/libgstapp-1.0.
dylib /opt/local/lib/libgstfft-1.0.dylib /opt/local/lib/libgstpbutils-1.0.dylib /opt/local/lib/libgstaudio-1.0.dylib /opt/local/lib/libgsttag-1.
0.dylib /opt/local/lib/libgstvideo-1.0.dylib /opt/local/lib/liborc-0.4.dylib /opt/local/lib/libgstbase-1.0.dylib /opt/local/lib/libgstreamer-1.0
.dylib -ldl /opt/local/lib/libjpeg.dylib /opt/local/lib/libsecret-1.dylib /opt/local/lib/libgcrypt.dylib /opt/local/lib/libgpg-error.dylib /opt/
local/lib/libxslt.dylib -lGL /opt/local/lib/libwebp.dylib /opt/local/lib/libXt.dylib /opt/local/lib/libSM.dylib /opt/local/lib/libICE.dylib /opt
/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_www_webkit-gtk/webkit-gtk/work/webkitgtk-2.0
.4/.libs/libjavascriptcoregtk-1.0.dylib -licui18n -licuuc -licudata /opt/local/lib/libgtk-x11-2.0.dylib /opt/local/lib/libgdk-x11-2.0.dylib /opt
/local/lib/libpangocairo-1.0.dylib /opt/local/lib/libXinerama.dylib /opt/local/lib/libXi.dylib /opt/local/lib/libXrandr.dylib /opt/local/lib/lib
Xcursor.dylib /opt/local/lib/libXcomposite.dylib /opt/local/lib/libXdamage.dylib /opt/local/lib/libXfixes.dylib /opt/local/lib/libatk-1.0.dylib 
/opt/local/lib/libcairo.dylib /opt/local/lib/libpixman-1.dylib /opt/local/lib/libxcb-shm.dylib /opt/local/lib/libX11-xcb.dylib /opt/local/lib/li
bxcb-render.dylib /opt/local/lib/libXrender.dylib /opt/local/lib/libXext.dylib /opt/local/lib/libX11.dylib /opt/local/lib/libxcb.dylib /opt/local/lib/libXau.dylib /opt/local/lib/libXdmcp.dylib /opt/local/lib/libgdk_pixbuf-2.0.dylib /opt/local/lib/libpangoft2-1.0.dylib /opt/local/lib/libharfbuzz.dylib /opt/local/lib/libgraphite2.dylib /opt/local/lib/libpango-1.0.dylib /opt/local/lib/libgthread-2.0.dylib /opt/local/lib/libfontconfig.dylib /opt/local/lib/libfreetype.dylib /opt/local/lib/libpng15.dylib -lbz2 /opt/local/lib/libexpat.dylib /opt/local/lib/libsoup-2.4.dylib /opt/local/lib/libxml2.dylib -lpthread /opt/local/lib/liblzma.dylib -lm /opt/local/lib/libsqlite3.dylib /opt/local/lib/libgio-2.0.dylib /opt/local/lib/libgmodule-2.0.dylib -lz /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libffi.dylib /opt/local/lib/libglib-2.0.dylib -lresolv /opt/local/lib/libintl.dylib /opt/local/lib/libiconv.dylib -lc -pthread
:info:build clang: warning: argument unused during compilation: '-pthread'
''':info:build dyld: Symbol not found: __cg_jpeg_resync_to_restart'''
:info:build   Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
:info:build   Expected in: /opt/local/lib/libjpeg.9.dylib

Change History (6)

Changed 8 years ago by iskaspb@…

Attachment: main.log.tar.bz2 added

main.log with build log and error

comment:1 Changed 8 years ago by iskaspb@…

Sorry error is illegible in previous message. Here is better formatting:

:info:build clang: warning: argument unused during compilation: '-pthread'
:info:build dyld: Symbol not found: __cg_jpeg_resync_to_restart
:info:build   Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
:info:build   Expected in: /opt/local/lib/libjpeg.9.dylib
:info:build  in /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO

comment:2 Changed 8 years ago by cooljeanius (Eric Gallager)

Duplicate of #39598

comment:3 Changed 8 years ago by iskaspb@…

Yes, indeed, this is duplicate of #39598

I managed to install webkit-gtk using proposed workaround (with --disable-introspection). For those who are not familiar with MarPorts configuration, please use the following steps:

  1. First you should find relevant Portfile:
$ find /opt/local -path '*webkit-gtk*Portfile' 

/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/www/webkit-gtk/Portfile
  1. Then open it and add --disable-introspection to this section of the file (don't forget backslash):
configure.args  \
        --with-gtk=2.0 \
        --disable-webkit2 \
        --enable-introspection \
        --disable-video \
        --enable-svg \
        --enable-geolocation \
        --enable-media-stream \
        --enable-webgl \
        --disable-introspection
  1. After that go to the folder of that Portfile and run:
$ sudo port install

comment:4 in reply to:  3 Changed 8 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)
Keywords: webkit-gtk removed
Resolution: duplicate
Status: newclosed

Please search Trac before posting tickets. There have been a plethora of tickets filed against this already.

Replying to iskaspb@…:

  1. First you should find relevant Portfile:
$ find /opt/local -path '*webkit-gtk*Portfile' 

/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/www/webkit-gtk/Portfile

Use port file webkit-gtk for this.

comment:5 Changed 8 years ago by larryv (Lawrence Velázquez)

Description: modified (diff)
Note: See TracTickets for help on using tickets.