Opened 8 years ago

Closed 8 years ago

#39884 closed defect (fixed)

wgrib2 @1.9.8 Configure error - build failure

Reported by: William.Capehart@… Owned by: tenomoto (Takeshi Enomoto)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc:
Port: wgrib2

Description (last modified by mf2k (Frank Schima))

There is a dependency / compiler error for the WGRIB2 resource.

Crash log below...

version:1
:msg:main --->  Computing dependencies for wgrib2:msg:main 
:debug:main wgrib2 has no conflicts
:debug:main Searching for dependency: gcc47
:debug:main Found Dependency: receipt exists for gcc47
:debug:main Searching for dependency: jasper
:debug:main Found Dependency: receipt exists for jasper
:debug:main Searching for dependency: libpng
:debug:main Found Dependency: receipt exists for libpng
:debug:main Searching for dependency: netcdf
:debug:main Found Dependency: receipt exists for netcdf
:debug:main Searching for dependency: hdf5-18
:debug:main Found Dependency: receipt exists for hdf5-18
:debug:main Executing org.macports.main (wgrib2)
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 501
:debug:main euid changed to: 501
:debug:archivefetch archivefetch phase started at Sun Jul 28 09:33:05 MDT 2013
:msg:archivefetch --->  Fetching archive for wgrib2
:debug:archivefetch Executing org.macports.archivefetch (wgrib2)
:debug:archivefetch euid/egid changed to: 0/0
:debug:archivefetch chowned /opt/local/var/macports/incoming to macports
:debug:archivefetch euid/egid changed to: 501/501
:info:archivefetch --->  wgrib2-1.9.8_0+gcc47.darwin_12.x86_64.tbz2 doesn't seem to exist in /opt/local/var/macports/incoming/verified
:msg:archivefetch --->  Attempting to fetch wgrib2-1.9.8_0+gcc47.darwin_12.x86_64.tbz2 from http://packages.macports.org/wgrib2
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404
:msg:archivefetch --->  Attempting to fetch wgrib2-1.9.8_0+gcc47.darwin_12.x86_64.tbz2 from http://lil.fr.packages.macports.org/wgrib2
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404
:msg:archivefetch --->  Attempting to fetch wgrib2-1.9.8_0+gcc47.darwin_12.x86_64.tbz2 from http://mse.uk.packages.macports.org/sites/packages.macports.org/wgrib2
:debug:archivefetch Fetching archive failed:: The requested URL returned error: 404
:debug:archivefetch Privilege de-escalation not attempted as not running as root.
:debug:fetch fetch phase started at Sun Jul 28 09:33:08 MDT 2013
:notice:fetch --->  Fetching distfiles for wgrib2
:debug:fetch Executing org.macports.fetch (wgrib2)
:debug:fetch Privilege de-escalation not attempted as not running as root.
:debug:checksum checksum phase started at Sun Jul 28 09:33:08 MDT 2013
:notice:checksum --->  Verifying checksums for wgrib2
:debug:checksum Executing org.macports.checksum (wgrib2)
:info:checksum --->  Checksumming wgrib2_nolib.tgz.v1.9.8
:debug:checksum Correct (md5) checksum for wgrib2_nolib.tgz.v1.9.8
:debug:checksum Correct (sha1) checksum for wgrib2_nolib.tgz.v1.9.8
:debug:checksum Correct (rmd160) checksum for wgrib2_nolib.tgz.v1.9.8
:debug:checksum Privilege de-escalation not attempted as not running as root.
:debug:extract extract phase started at Sun Jul 28 09:33:08 MDT 2013
:notice:extract --->  Extracting wgrib2
:debug:extract Executing org.macports.extract (wgrib2)
:info:extract --->  Extracting wgrib2_nolib.tgz.v1.9.8
:debug:extract setting option extract.args to '/opt/local/var/macports/distfiles/wgrib2/wgrib2_nolib.tgz.v1.9.8'
:debug:extract Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.8'
:debug:extract Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work" && /usr/bin/gzip -dc '/opt/local/var/macports/distfiles/wgrib2/wgrib2_nolib.tgz.v1.9.8' | /usr/bin/gnutar --no-same-owner -xf -'
:debug:extract Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work" && /usr/bin/gzip -dc '/opt/local/var/macports/distfiles/wgrib2/wgrib2_nolib.tgz.v1.9.8' | /usr/bin/gnutar --no-same-owner -xf - 
:debug:extract euid/egid changed to: 0/0
:debug:extract chowned /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work to macports
:debug:extract euid/egid changed to: 501/501
:debug:extract Privilege de-escalation not attempted as not running as root.
:debug:patch patch phase started at Sun Jul 28 09:33:08 MDT 2013
:debug:patch Executing org.macports.patch (wgrib2)
:notice:patch --->  Applying patches to wgrib2
:info:patch --->  Applying patch-makefile.diff
:debug:patch Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.8'
:debug:patch Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2" && /usr/bin/patch -p0'
:debug:patch Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2" && /usr/bin/patch -p0 < '/opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports/science/wgrib2/files/patch-makefile.diff'
:info:patch patching file makefile
:debug:patch Privilege de-escalation not attempted as not running as root.
:debug:configure configure phase started at Sun Jul 28 09:33:08 MDT 2013
:notice:configure --->  Configuring wgrib2
:debug:configure Using compiler 'Mac OS X Clang'
:debug:configure Executing org.macports.configure (wgrib2)
:debug:configure Privilege de-escalation not attempted as not running as root.
:debug:build build phase started at Sun Jul 28 09:33:08 MDT 2013
:notice:build --->  Building wgrib2
:debug:build Executing org.macports.build (wgrib2)
:debug:build port disallows a parallel build
:debug:build Environment: CPPFLAGS='-DGFORTRAN -I/opt/local/include' CFLAGS='-Os -arch x86_64' CPATH='/opt/local/include' MACOSX_DEPLOYMENT_TARGET='10.8' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/.CC_PRINT_OPTIONS' LDFLAGS='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2/g2clib-1.4.0/libgrib2c.a /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2/gctpc/source/libgeo.a /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2/iplib.2012/libipolate.a -L/opt/local/lib/gcc47 -lgfortran -L/opt/local/lib -Wl,-headerpad_max_install_names -lpng -ljasper -lnetcdf' F90='/opt/local/bin/gcc-mp-4.7' FC='/opt/local/bin/gcc-mp-4.7' FFLAGS='-Os' CC_PRINT_OPTIONS='YES' CC='/usr/bin/clang'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2" && /usr/bin/make -w all -f makefile  zlib="" plib="" jlib="" h5lib="" n4lib=""  iip="-I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2/iplib.2012"  USE_IPOLATES=1 USE_OPENMP=1'
:debug:build Executing command line:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2" && /usr/bin/make -w all -f makefile  zlib="" plib="" jlib="" h5lib="" n4lib=""  iip="-I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2/iplib.2012"  USE_IPOLATES=1 USE_OPENMP=1 
:info:build make: Entering directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2'
:info:build makefile:292: *** ERROR, did not recognize fortran compiler, cannot use IPOLATES, set FC=f90 compiler.  Stop.
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2" && /usr/bin/make -w all -f makefile  zlib="" plib="" jlib="" h5lib="" n4lib=""  iip="-I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/work/grib2/iplib.2012"  USE_IPOLATES=1 USE_OPENMP=1 
:info:build Exit code: 2
:error:build org.macports.build for port wgrib2 returned: command execution failed
:debug:build Error code: CHILDSTATUS 38844 2
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for wgrib2: org.macports.install org.macports.build org.macports.destroot
:notice:build Please see the log file for port wgrib2 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_science_wgrib2/wgrib2/main.log

Change History (5)

comment:1 Changed 8 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to takeshi@…
Port: wgrib2 added
Type: updatedefect

In the future, please read the ticket guidelines. You did not fill in the Port field, Cc the port maintainer(s) and attach the main.log instead of pasting it inline sans WikiFormatting.

comment:2 Changed 8 years ago by tenomoto (Takeshi Enomoto)

The build probably failed because FC is set to be gcc-mp-4.7 and makefile can't find string gfortran in FC. I was unable to reproduced the error, but committed in r108625. Let me know if this fixed the problem.

comment:3 Changed 8 years ago by ryandesign (Ryan Schmidt)

Is this still a problem?

comment:4 Changed 8 years ago by William.Capehart@…

No, all seems to be well. wgib2 works also on the Mavericks build. I think this can be closed. (Thanks Takeshi!)

comment:5 Changed 8 years ago by tenomoto (Takeshi Enomoto)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.