Opened 7 years ago

Closed 7 years ago

#40097 closed defect (fixed)

FreeRDP @1.1.0-beta-2013071101_3: Build fails on SL buildbot

Reported by: dbevans (David B. Evans) Owned by: anddam (Andrea D'Amore)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: snowleopard Cc: cooljeanius (Eric Gallager), jeremyhu (Jeremy Huddleston Sequoia)
Port: FreeRDP

Description (last modified by anddam (Andrea D'Amore))

After recent commits for this port, buildbots are successful for ML and Lion but SL fails with this error:

Compiling /opt/local/var/macports/build/_opt_mports_dports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/Mac/PasswordDialog.xib
cd /opt/local/var/macports/build/_opt_mports_dports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/Mac && /usr/bin/ibtool --errors --warnings --notices --output-format human-readable-text --compile /opt/local/var/macports
/build/_opt_mports_dports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/Mac//MacFreeRDP-library.app/Contents/Resources/PasswordDialog.nib /opt/local/var/macports/build/_opt_mports_dports_net_FreeRDP/FreeRDP/work/FreeRDP-
1.1.0-beta+2013071101/client/Mac/PasswordDialog.xib
2014-03-02 23:42:24.828 ibtool[57468:907] Exception raised while decoding document objects - Could not instantiate class named IBNSLayoutConstraint
/* com.apple.ibtool.errors */
/opt/local/var/macports/build/_opt_mports_dports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/Mac/PasswordDialog.xib: error: The document "PasswordDialog.xib" could not be opened. An instance of IBNSLayoutConstraint cou
ld not be decoded.
    Recovery Suggestion: Ensure all plug-ins used to create this document have been loaded.

Build log attached.

Attachments (1)

buildbot-sl-build.log (3.7 MB) - added by dbevans (David B. Evans) 7 years ago.
Buildbot SL log showing failure

Change History (9)

Changed 7 years ago by dbevans (David B. Evans)

Attachment: buildbot-sl-build.log added

Buildbot SL log showing failure

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Keywords: snowleopard added

comment:2 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:3 Changed 7 years ago by rogerpack2005@…

Odd.

for me on SL I get also a failure, but different:

_opt_rdp_project_local_var_macports_sources_distfiles.macports.org_ports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/common/client.c

cc1: error: unrecognized command line option “-fobjc-nonfragile-abi”

comment:4 in reply to:  3 ; Changed 7 years ago by dbevans (David B. Evans)

Replying to rogerpack2005@…:

Odd.

for me on SL I get also a failure, but different:

_opt_rdp_project_local_var_macports_sources_distfiles.macports.org_ports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/common/client.c

cc1: error: unrecognized command line option “-fobjc-nonfragile-abi”

This, indeed, looks like a separate issue so you should submit a separate ticket and attach a copy of your full build log showing the error.

sudo port clean FreeRDP
sudo port build FreeRDP
port log FreeRDP > build.log

comment:5 in reply to:  4 Changed 7 years ago by anddam (Andrea D'Amore)

Replying to rogerpack2005@…: _opt_rdp_project_local_var_macports_sources_distfiles.macports.org_ports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/common/client.c

cc1: error: unrecognized command line option “-fobjc-nonfragile-abi”

Replying to devans@…:

This, indeed, looks like a separate issue so you should submit a separate ticket and attach a copy of your full build log showing the error.

Actually I see both errors in the log you attached.

I couldn't reproduce that since I didn't have access to a SL system, meanwhile the portfile has been updated and checking the latest SL buildbot log involving FreeRDP the error now is:

Compiling /opt/local/var/macports/build/_opt_mports_dports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/Mac/PasswordDialog.xib
cd /opt/local/var/macports/build/_opt_mports_dports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/Mac && /usr/bin/ibtool --errors --warnings --notices --output-format human-readable-text --compile /opt/local/var/macports
/build/_opt_mports_dports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/Mac//MacFreeRDP-library.app/Contents/Resources/PasswordDialog.nib /opt/local/var/macports/build/_opt_mports_dports_net_FreeRDP/FreeRDP/work/FreeRDP-
1.1.0-beta+2013071101/client/Mac/PasswordDialog.xib
2014-03-02 23:42:24.828 ibtool[57468:907] Exception raised while decoding document objects - Could not instantiate class named IBNSLayoutConstraint
/* com.apple.ibtool.errors */
/opt/local/var/macports/build/_opt_mports_dports_net_FreeRDP/FreeRDP/work/FreeRDP-1.1.0-beta+2013071101/client/Mac/PasswordDialog.xib: error: The document "PasswordDialog.xib" could not be opened. An instance of IBNSLayoutConstraint cou
ld not be decoded.
    Recovery Suggestion: Ensure all plug-ins used to create this document have been loaded.
make[2]: *** [client/Mac/MacFreeRDP.framework/Versions/1.1.0/MacFreeRDP] Error 1

So I'm trying to disable use of autolayout when the build system is SnowLeopard in post-patch.

comment:6 Changed 7 years ago by anddam (Andrea D'Amore)

Description: modified (diff)

comment:7 Changed 7 years ago by anddam (Andrea D'Amore)

Cc: jeremyhu@… added

I edited the description and added Jeremy to CC list.

comment:8 Changed 7 years ago by anddam (Andrea D'Amore)

Resolution: fixed
Status: newclosed

I added XIB without Auto Layout option (converted using XCode 5.1) in order to replace those in source tree.

The build went through in SL buildbot, I'm closing the ticket.

Note: See TracTickets for help on using tickets.