Opened 15 years ago

Closed 15 years ago

#4010 closed defect (fixed)

BUG: Wrong directions from PHP4

Reported by: frankalahan@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: bchesneau@…, mww@…, joelmichael@…
Port:

Description

I installed php4 this way, notice the note after instalation

[~/Development/IC/work]$ sudo port install php4 +mysql +apache2 ---> Fetching php4 ---> Attempting to fetch php-4.4.0.tar.bz2 from http://www.php.net/distributions/ ---> Verifying checksum(s) for php4 ---> Extracting php4 ---> Configuring php4 ---> Building php4 with target all ---> Staging php4 into destroot ---> Packaging tgz archive for php4 4.4.0_0+apache2+macosx+mysql ---> Installing php4 4.4.0_0+apache2+macosx+mysql

If this your first install, you might want cd /opt/local/apache2/libs apxs -a -e -n "php4" libphp4.so

  • copy /opt/local/etc/php.ini-dist to /opt/local/etc/php.ini
  • copy /opt/local/etc/pear.conf.sample to /opt/local/etc/pear.conf

---> Activating php4 4.4.0_0+apache2+macosx+mysql ---> Cleaning php4

The problem is that route doesn't exist, instead, I tried /opt/local/apache2/modules, since I saw libphp4.so, howerver, after doing the rest, I get next error message from apachectl start

Syntax error on line 276 of /opt/local/apache2/conf/httpd.conf: Cannot load /opt/local/apache2/modules/libphp4.so into server: Symbol not found: cg_jpeg_resync_to_restart\n Referenced from: /System/Library/Frameworks/ ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO\n Expected in: /opt/local/lib/libJPEG.dylib\n

Worked fine before installing PHP4

By the way, the note talks about apxs, but I think it should say /opt/local/apache2/bin/apxs so it won't use MacosX default Apache server

Change History (6)

comment:1 Changed 15 years ago by frankalahan@…

severity: minornormal

php5 also has this bug

comment:2 Changed 15 years ago by peter@…

Cc: bchesneau@… added

I changed the php4 Portfile to include the right apxs command en modules directory. This works for me (10.3.9)

* Portfile Tue Jul 12 15:46:32 2005 --- Portfile.new Thu Jul 21 21:11:01 2005 * * 3,8 --- 3,9 ----

PortSystem 1.0 name php4 version 4.4.0

+ revision 1

categories lang www maintainers bchesneau@… description PHP: Hypertext Preprocessor

* * 219,231

ui_msg "cd ${prefix}/libexec/apache"

}

! ui_msg "apxs -a -e -n \"php4\" libphp4.so\n"

ui_msg "* copy ${prefix}/etc/php.ini-dist to ${prefix}/etc/php.ini"

}

if { [variant_isset apache2] } {

! ui_msg "cd ${prefix}/apache2/libs" ! ui_msg "apxs -a -e -n \"php4\" libphp4.so\n"

ui_msg "* copy ${prefix}/etc/php.ini-dist to ${prefix}/etc/php.ini"

}

--- 220,232 ----

ui_msg "cd ${prefix}/libexec/apache"

}

! ui_msg "${prefix}/apache/bin/apxs -a -e -n \"php4\" libphp4.so\n"

ui_msg "* copy ${prefix}/etc/php.ini-dist to ${prefix}/etc/php.ini"

}

if { [variant_isset apache2] } {

! ui_msg "cd ${prefix}/apache2/modules" ! ui_msg "${prefix}/apache2/bin/apxs -a -e -n \"php4\" libphp4.so\n"

ui_msg "* copy ${prefix}/etc/php.ini-dist to ${prefix}/etc/php.ini"

}

comment:3 Changed 15 years ago by peter@…

Cc: mww@… added

Some thing for the php5 Portfile:

* Portfile Mon Jul 11 11:46:21 2005 --- Portfile.new Thu Jul 21 22:07:01 2005 * * 4,9 --- 4,10 ----

name php5 version 5.0.4

+ revision 1

categories lang www maintainers darwinports@… description PHP: Hypertext Preprocessor

* * 183,189

}

post-install {

! ui_msg "\nIf this your first install, you might want"

if { [variant_isset apache] } {

ui_msg " * enable php in apache :\n"

--- 184,190 ----

}

post-install {

! ui_msg "\nIf this is your first install, you might want"

if { [variant_isset apache] } {

ui_msg " * enable php in apache :\n"

* * 194,206

ui_msg "cd ${prefix}/libexec/apache"

}

! ui_msg "apxs -a -e -n \"php5\" libphp5.so\n"

ui_msg "* copy ${prefix}/etc/php.ini-dist to ${prefix}/etc/php.ini"

}

if { [variant_isset apache2] } {

! ui_msg "cd ${prefix}/apache2/libs" ! ui_msg "apxs -a -e -n \"php5\" libphp5.so\n"

ui_msg "* copy ${prefix}/etc/php.ini-dist to ${prefix}/etc/php.ini"

}

--- 195,208 ----

ui_msg "cd ${prefix}/libexec/apache"

}

! ui_msg "${prefix}/apache/bin/apxs -a -e -n \"php5\" libphp5.so\n"

ui_msg "* copy ${prefix}/etc/php.ini-dist to ${prefix}/etc/php.ini"

}

if { [variant_isset apache2] } {

! ui_msg " * enable php in apache :\n" ! ui_msg "cd ${prefix}/apache2/modules" ! ui_msg "${prefix}/apache2/bin/apxs -a -e -n \"php5\" libphp5.so\n"

ui_msg "* copy ${prefix}/etc/php.ini-dist to ${prefix}/etc/php.ini"

}

comment:4 Changed 15 years ago by mww@…

Cc: joelmichael@… added

* Bug 3987 has been marked as a duplicate of this bug. *

comment:5 Changed 15 years ago by mww@…

Summary: Wrong directions from PHP4BUG: Wrong directions from PHP4

comment:6 Changed 15 years ago by blb@…

Resolution: fixed
Status: newclosed

php4 and php5 have been corrected, thanks for the report.

Note: See TracTickets for help on using tickets.