Opened 8 years ago

Last modified 8 years ago

#40107 new request

openni2: create port for 2.2.0.30

Reported by: aa@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: openni2

Description

Hi,

First of all: I can't express my gratitude to Macports enough. Seamless integration that brings the best of two worlds to OS X. Thank You Very Much Indeed.

Secondly: I've noticed that OpenNI on Macports is still at version 1.x and I'd like to know if that port will remain so or if it will be upgraded to 2.x

In the first case I'll be glad to know if there will be a separate port as OpenNI-2 as well.

Thank You

-- aa

Change History (19)

comment:1 Changed 8 years ago by aa@…

Cc: aa@… added

Cc Me!

comment:2 Changed 8 years ago by larryv (Lawrence Velázquez)

Cc: aa@… removed
Keywords: upgrade new version removed
Milestone: MacPorts Future
Owner: changed from macports-tickets@… to ryandesign@…
Summary: OpenNI 2 v2.2.0.30openni @1.5.2.23: update to 2.2.0.30
Type: requestupdate

Thanks for the ticket. In the future, please Cc relevant port maintainers (port info --maintainers).

comment:3 Changed 8 years ago by aa@…

I'm sorry for the mistake, first ticket here.

Thank You Cheers

comment:4 Changed 8 years ago by aa@…

Hi Ryan,

I hope you don't mind me giving just a ping. I'd kindly like to know which route will you take:

1 - upgrade this very port from 1.5.x to 2.2.x?

2 - make a separate port just for 2.2.x and keep this at 1.5.x?

Please Thank You

-- aa

comment:5 Changed 8 years ago by aa@…

Cc: aa@… added

Cc Me!

comment:6 Changed 8 years ago by aa@…

sorry for the cc. I just wanted to add macports there.

my bad.

comment:7 Changed 8 years ago by ryandesign (Ryan Schmidt)

Sorry to have ignored this ticket. I'm not familiar with openni, and I think I only added the port because it was needed for another port, which then didn't get added? If anybody else is interested in maintaining openni that would be fine with me.

"port livecheck openni" says we're at the latest version. Where is openni 2?

The only ports that depend on openni today are libpcl and a variant of opencv. If we consider updating the openni port to version 2 we would first want to ensure that those ports still work with that version. If either of them don't, that would be a good excuse for creating a new openni2 port instead.

comment:8 Changed 8 years ago by aa@…

Hi Ryan,

finally!!! :)

OpenNI 2 can be found here http://www.openni.org/openni-sdk/ and here: https://github.com/OpenNI/OpenNI2 ; it would be great to have the latest version into Macports.

Regarding a new port only for version 2.x is up to you. I'd try maintaining if necessary. I've never done a port before but I was an Arch Linux AUR maintainer for a few packages until some time ago. I don't think it differs much. Just let me know.

Waiting for the port upgrade :)

Thank You

comment:9 Changed 8 years ago by ryandesign (Ryan Schmidt)

The migration guide says "OpenNI 2 represents a major change in the underlying design philosophy of OpenNI" and "Unfortunately, this redesign has required us to break backward compatibility with OpenNI 1.5.2." This seems like sufficient reason to make a separate port for openni2.

comment:10 Changed 8 years ago by aa@…

Hi Ryan,

will you make one?

comment:11 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: aa@… removed
Port: openni2 added; openni removed
Summary: openni @1.5.2.23: update to 2.2.0.30openni2: create port for 2.2.0.30
Type: updaterequest
Version: 2.2.0

comment:12 Changed 8 years ago by aa@…

great thank you :)

comment:13 Changed 8 years ago by aa@…

Hi Ryan,

I've bumped the post on Github.

It's annoying that they don't provide source code already, let alone not answering. :/

comment:14 Changed 8 years ago by aa@…

Hi Ryan,

they answered!!!

looking forward for your package :D

comment:15 Changed 8 years ago by aa@…

ping

comment:16 Changed 8 years ago by ryandesign (Ryan Schmidt)

I have it building, but I still need to do something to get the destroot phase to complete.

comment:17 Changed 8 years ago by aa@…

Hi Ryan,

good news then :)

how is it coming?

best,

comment:18 Changed 8 years ago by aa@…

Hi Ryan,

I know I'm stressing you, but I need OpenNI badly.

Did you solve the destroot?

Thanks

comment:19 Changed 8 years ago by aa@…

Hi Ryan,

do not worry about it, I switched to brew and installed OpenNI 1 and 2 from there.

cheers

Note: See TracTickets for help on using tickets.