Opened 8 years ago

Closed 8 years ago

#40137 closed defect (fixed)

mythtv-core.26 @0.26-Fixes-20130720 frontend crashes at Program Details

Reported by: y-lee (Yeechang Lee) Owned by: ctreleaven (Craig Treleaven)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc:
Port: mythtv-core.26

Description

OS X 10.8.4 Late 2008 15" Macbook Pro (Core 2 Duo) Xcode 4.6.3, build 4H1503

When I attempt to view Program Details, MythFrontend crashes with

Handling Segmentation fault: 11

in a dialog box and the attached output from the OS X crash reporter. This does not happen with Jean-Yves Avenard's standalone frontend binary.

Attachments (1)

mythtv-core.26.crash.log (68.0 KB) - added by y-lee (Yeechang Lee) 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by y-lee (Yeechang Lee)

Attachment: mythtv-core.26.crash.log added

comment:1 Changed 8 years ago by larryv (Lawrence Velázquez)

Keywords: mythfrontend removed
Owner: changed from macports-tickets@… to ctreleaven@…

Thanks for the ticket. In the future, please Cc relevant port maintainers (port info --maintainers).

comment:2 Changed 8 years ago by ctreleaven (Craig Treleaven)

This appears to be the same issue that arose with mythtv-core.25:

https://trac.macports.org/ticket/35934

Of which, I never did determine the root cause. Eventually, clearing all of the default MacPorts compile and link flags seemed to alleviate the problem but I have not found the right combination for 0.26. As with 0.25, I've found that choosing another compiler seems to work: clang-3.0 in this case. Could you please try the following:

Install clang-3.0:

sudo port install clang-3.0

Build myth 0.26 with it:

sudo port -d install mythtv-core.26 configure.compiler=macports-clang-3.0

So far, I've tested clang 3.4, 3.2 and 3.0. Myth builds with all three but only the 3.0 build starts up successfully. If I get a couple of reports of success, I'll modify the portfile to do this automatically.

Also, if anyone experiences this issue on 10.6 or 10.7, please speak up.

comment:3 Changed 8 years ago by y-lee (Yeechang Lee)

clang-3.0 indeed fixes the Program Details crash problem; thank you. Will report if I find other issues.

comment:4 Changed 8 years ago by pixilla (Bradley Giesbrecht)

Resolution: fixed
Status: newclosed

See r111984

Note: See TracTickets for help on using tickets.