Opened 7 years ago

Closed 7 years ago

#40144 closed defect (fixed)

libgnomeui -x11 has unsubstituted @SM_LIBS@ in pkgconfig

Reported by: daniel@… Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: maverickwoo (Maverick Woo)
Port: libgnomeui

Description

See:

$ grep Libs /opt/local/lib/pkgconfig/libgnomeui-2.0.pc
Libs: -L${libdir} -lgnomeui-2 @SM_LIBS@

This causes other builds (py27-gnome, for instance) to fail. It seems like r107414 is the culprit here.

Change History (4)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: devans@… removed
Owner: changed from macports-tickets@… to devans@…

comment:2 Changed 7 years ago by maverickwoo (Maverick Woo)

Cc: maverick.woo@… added

Cc Me!

comment:3 Changed 7 years ago by neverpanic (Clemens Lang)

Owner: changed from devans@… to cal@…
Status: newassigned
Summary: libgnomeui +no_x11 has unsubstituted @SM_LIBS@ in pkgconfiglibgnomeui -x11 has unsubstituted @SM_LIBS@ in pkgconfig

comment:4 Changed 7 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: assignedclosed

Fixed in r111807.

Note: See TracTickets for help on using tickets.