Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#40193 closed defect (fixed)

pandoc @1.11.1_3: configure cannot detect several dependencies

Reported by: smasson@… Owned by: neverpanic (Clemens Lang)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: neverpanic (Clemens Lang), seanfarley (Sean Farley), muchatel@…
Port: pandoc

Description (last modified by larryv (Lawrence Velázquez))

I am using port Version: 2.2.0 on OS X 10.8.4

threre is the log of sudo port install pandoc: attachment:main.log

threre is the output of port installed 'hs-*': attachment:installed-hs.txt

threre is the output of ghc-pkg list: attachment:ghc-pkg-list.txt

threre is the output of ghc-pkg check: attachment:ghc-pkg-check.txt

Attachments (4)

main.log (72.9 KB) - added by larryv (Lawrence Velázquez) 7 years ago.
installed-hs.txt (1.3 KB) - added by larryv (Lawrence Velázquez) 7 years ago.
output of "port installed 'hs-*'"
ghc-pkg-list.txt (1.0 KB) - added by larryv (Lawrence Velázquez) 7 years ago.
output of "ghc-pkg list"
ghc-pkg-check.txt (4.7 KB) - added by larryv (Lawrence Velázquez) 7 years ago.
output of "ghc-pkg check"

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by larryv (Lawrence Velázquez)

Attachment: main.log added

Changed 7 years ago by larryv (Lawrence Velázquez)

Attachment: installed-hs.txt added

output of "port installed 'hs-*'"

Changed 7 years ago by larryv (Lawrence Velázquez)

Attachment: ghc-pkg-list.txt added

output of "ghc-pkg list"

Changed 7 years ago by larryv (Lawrence Velázquez)

Attachment: ghc-pkg-check.txt added

output of "ghc-pkg check"

comment:1 Changed 7 years ago by larryv (Lawrence Velázquez)

Cc: cal@… sean@… added; smasson@… removed
Description: modified (diff)
Summary: pandoc @1.11.1_3 - build failurepandoc @1.11.1_3: configure cannot detect several dependencies
Version: 2.2.0

Thanks for the ticket. Your formatting is appreciated, but in the future please just provide log files and the like as attachments. Putting tons of text into the description generates huge emails to macports-tickets, even if the text is in a textarea.

comment:2 Changed 7 years ago by neverpanic (Clemens Lang)

Owner: changed from macports-tickets@… to cal@…
Status: newassigned

I think the problem might be that I didn't revbump all haskell ports when updating GHC to 7.6.3.

comment:3 Changed 7 years ago by gnw3

I have Snow Leopard 10.6.8 with macports 2.2.0.

The pandoc @1.11.1_3 install failed after rebuilding all the hs-* packages:

--->  Configuring pandoc
Error: org.macports.configure for port pandoc returned: configure failure: command execution failed
Please see the log file for port pandoc for details:

The pertinent log contents:

:info:configure Setup: At least the following dependencies are missing:
:info:configure tagsoup >=0.12.5 && <0.13

Macports provides hs-tagsoup @0.13_0.

comment:4 Changed 7 years ago by muchatel@…

I can reproduce the problem. Downgrading hs-tagsoup to @0.12.8_2 solved it.

comment:5 Changed 7 years ago by muchatel@…

Cc: muchatel@… added

Cc Me!

comment:6 Changed 7 years ago by neverpanic (Clemens Lang)

Resolution: fixed
Status: assignedclosed

I think r110047 fixes this. Please re-open if the problem persists.

comment:7 Changed 7 years ago by smasson@…

It works for me. thank you.

Note: See TracTickets for help on using tickets.