Opened 7 years ago

Closed 7 years ago

#40240 closed defect (fixed)

Incompatible versions between SIP and popplerqt4 module

Reported by: philmassart@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: phw@…, dbevans (David B. Evans)
Port: poppler, py-sip, qt4-mac py-pyqt4

Description (last modified by ryandesign (Ryan Schmidt))

Update to the last versions of py-sip and qt4 make them incompatible with poppler. I get that kind of message (depending of qt4 and poppler versions):

the sip module implements API v10.0 to v10.1 but the PyQt4.QtCore module requires API v9.2

or

the sip module implements API v10.0 to v10.1 but the popplerqt4 module requires API v9.1

I guess the best would be to update popplerqt4 to accept the latest versions of sip.

To avoid the problem, I need to reactivate older versions of py-sip and pyqt4, but for new users of those ports it's much more difficult

Change History (5)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: phw@… devans@… added
Description: modified (diff)
Keywords: sip pyqt poppler removed
Owner: changed from macports-tickets@… to michaelld@…
Port: py-sip py-pyqt4 added; sip pyqt4 removed

comment:2 Changed 7 years ago by michaelld (Michael Dickens)

In the past, the solution was to rev-bump the SIP dependencies such that they would be rebuilt with the new SIP API version. The listed errors are printed when trying to import a project that uses SIP, but was compiled with an older API version. Thus, try uninstalling (-f if necessary) the dependencies and then reinstalling them; hopefully that will take care of the issue. If not, we'll work on some other solution.

comment:3 in reply to:  2 Changed 7 years ago by philmassart@…

Replying to michaelld@…:

In the past, the solution was to rev-bump the SIP dependencies such that they would be rebuilt with the new SIP API version. The listed errors are printed when trying to import a project that uses SIP, but was compiled with an older API version. Thus, try uninstalling (-f if necessary) the dependencies and then reinstalling them; hopefully that will take care of the issue. If not, we'll work on some other solution.

I re-compiled the software that uses sip, poppler and qt4 and it works now.

Thanks !

comment:4 Changed 7 years ago by michaelld (Michael Dickens)

Great; thanks for the reply. What this means is we need to rev-bump ports that use SIP in this manner.

comment:5 Changed 7 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: newclosed

Fixed in various revisions. Thanks for reporting the issue. I didn't see it, and don't always remember to rev-bump because of an API change. I'll add a note to the SIP port to do so in the future.

Note: See TracTickets for help on using tickets.