Opened 7 years ago

Closed 7 years ago

#40252 closed defect (fixed)

octave-devel: undefined symbols

Reported by: skymoo (Adam Mercer) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: AP1010
Port: octave-devel

Description

In building octave-devel @3.6.4_7 I'm running into the following build error:

:info:build Undefined symbols for architecture x86_64:
:info:build   "__gfortran_concat_string", referenced from:
:info:build       _cgesvd_ in liblapack.a(cgesvd.o)
:info:build       _dgesvd_ in liblapack.a(dgesvd.o)
:info:build       _sgesvd_ in liblapack.a(sgesvd.o)
:info:build       _zgesvd_ in liblapack.a(zgesvd.o)
:info:build       _chseqr_ in liblapack.a(chseqr.o)
:info:build       _cunmbr_ in liblapack.a(cunmbr.o)
:info:build       _cunmlq_ in liblapack.a(cunmlq.o)
:info:build       ...
:info:build   "__gfortran_pow_i4_i4", referenced from:
:info:build       _clalsa_ in liblapack.a(clalsa.o)
:info:build       _dlalsa_ in liblapack.a(dlalsa.o)
:info:build       _dlasd0_ in liblapack.a(dlasd0.o)
:info:build       _dlasda_ in liblapack.a(dlasda.o)
:info:build       _slalsa_ in liblapack.a(slalsa.o)
:info:build       _slasd0_ in liblapack.a(slasd0.o)
:info:build       _slasda_ in liblapack.a(slasda.o)
:info:build       ...
:info:build ld: symbol(s) not found for architecture x86_64

The full build log is attached.

Attachments (1)

main.log (848.9 KB) - added by skymoo (Adam Mercer) 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by skymoo (Adam Mercer)

Attachment: main.log added

comment:1 Changed 7 years ago by michaelld (Michael Dickens)

I get this too. "It's not my fault!" I'm looking into it.

comment:2 Changed 7 years ago by AP1010

Cc: arthur@… added

Cc Me!

comment:3 Changed 7 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: newclosed

Fixed in r110134.

Note: See TracTickets for help on using tickets.