Opened 6 years ago

Closed 6 years ago

#40253 closed defect (fixed)

mapserver @6.2.1_0 fails to detect that gd 2.1.0 is new enough

Reported by: jea@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc:
Port: mapserver

Description

When trying to make the new version of mapserver @6.2.1_0 it wouldn't configure unless I activated the old @2.0.35_14 version of gd2, instead of the newer d2 @2.1.0_3+x11

Has it been tested with gd@2.1? Is this just a dependency checking problem? There's probably a way in the macports system to require the backport of gd2 if necessary, or to allow the most recent version otherwise.

Change History (3)

comment:1 Changed 6 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… removed
Owner: changed from macports-tickets@… to ryandesign@…
Port: gd2 removed
Status: newassigned
Summary: mapserver @6.2.1_0 requires gd @2.0 instead of @2.1?mapserver @6.2.1_0 fails to detect that gd 2.1.0 is new enough

mapserver needs a patch for gd2 2.1 compatibility (it has faulty version detection code in its configure script). I had been working on this but reached some resistance from the developer regarding the correct way to write the patch and lack of interest on their part in solving it all since the next version of mapserver uses cmake and doesn't have this bug. I will probably just commit the patch I wrote anyway.

comment:2 Changed 6 years ago by ryandesign (Ryan Schmidt)

comment:3 Changed 6 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.