Opened 7 years ago

Closed 7 years ago

#40254 closed defect (duplicate)

mapserver @6.2.1_0 +apache2 installs script in /opt/local/apache2/cgi-bin

Reported by: jea@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: jea@…
Port: mapserver

Description (last modified by ryandesign (Ryan Schmidt))

The mapserver install copies a bash script into the /opt/local/apache2/cgi-bin directory, and then apache complains

[Mon Aug 26 13:58:58 2013] [error] [client 127.0.0.1] /opt/local/apache2/cgi-bin/mapserv: error: `/opt/local/apache2/cgi-bin/.libs/mapserv' does not exist
[Mon Aug 26 13:58:58 2013] [error] [client 127.0.0.1] This script is just a wrapper for mapserv.
[Mon Aug 26 13:58:58 2013] [error] [client 127.0.0.1] See the libtool documentation for more information.
[Mon Aug 26 13:58:58 2013] [error] [client 127.0.0.1] Premature end of script headers: mapserv

I've been able to get macports @6.2.1_0 working with macports apache 2 if I copy the binary to the cgi-bin directory

sudo cp /opt/local/bin/mapserv /opt/local/apache2/cgi-bin/mapserv

but the installer should probably do that somehow.

PS The script clearly states

# This wrapper script should never be moved out of the build directory.
# If it is, it will not operate correctly.

Change History (1)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Cc: jea@… added; ryandesign@… removed
Description: modified (diff)
Resolution: duplicate
Status: newclosed

Duplicate of #38033.

Note: See TracTickets for help on using tickets.