Opened 7 years ago

Closed 7 years ago

#40273 closed defect (duplicate)

mysql55: "The server quit without updating PID file"

Reported by: eric.lebigot@… Owned by: pixilla (Bradley Giesbrecht)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: tdsimpson@…
Port: mysql55

Description

When I start mysql with

sudo /opt/local/share/mysql55/support-files/mysql.server start

it fails with

Starting MySQL
. ERROR! The server quit without updating PID file (/opt/local/var/db/mysql55/weinberg.local.pid).

It used to work (I believe before the August 5th, 2013 version), and I haven't touched MySQL.

The error logs in /opt/local/var/db/mysql55 are created by are empty.

I searched the web for solutions, tried many things (changing permissions, ownerships, deleting log files,…), to no avail.

Change History (8)

comment:1 Changed 7 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to pixilla@…
Port: mysql55 added

comment:2 Changed 7 years ago by eric.lebigot@…

PS: I get the exact same problem with mysql56 after installing it.

comment:3 Changed 7 years ago by tdsimpson@…

Cc: tdsimpson@… added

Cc Me!

comment:4 Changed 7 years ago by auke@…

I found the problem (at least in mysql56). It's an if-statement in /opt/local/lib/mysql56/bin/mysqld_safe at line 725.

When you remove lines 725, 726 and 729 from mysqld_safe, the server will start.

comment:5 Changed 7 years ago by eric.lebigot@…

Yeah, something like this. :)

There is actually another ticket (https://trac.macports.org/ticket/40040) that indicates that an "if" test is missing. Line 726 of /opt/local/lib/mysql55/bin/mysqld_safe should be:

if ps -ef | grep -v mysqld_safe | grep -- $MYSQLD | grep $PID > /dev/null

Last edited 7 years ago by eric.lebigot@… (previous) (diff)

comment:6 in reply to:  5 Changed 7 years ago by burtonpatrick0@…

Replying to eric.lebigot@…:

Yeah, something like this. :)

There is actually another ticket (https://trac.macports.org/ticket/40040) that indicates that an "if" test is missing. Line 726 of /opt/local/lib/mysql55/bin/mysqld_safe should be:

if ps -ef | grep -v mysqld_safe | grep -- $MYSQLD | grep $PID > /dev/null

Just to clarify. You mean line 725 should read if ps -ef | grep -v mysqld_safe | grep -- $MYSQLD | grep $PID > /dev/null not 726. I just modified the line for 725 and it worked. Thanks for the tip!

comment:7 Changed 7 years ago by eric.lebigot@…

Yes, indeed, you're right.

Last edited 7 years ago by eric.lebigot@… (previous) (diff)

comment:8 Changed 7 years ago by pixilla (Bradley Giesbrecht)

Resolution: duplicate
Status: newclosed

Duplicate of #40040

Note: See TracTickets for help on using tickets.