Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#40282 closed defect (fixed)

gstreamer1-gst-plugins-base +no_x11 still pulls in x11 deps

Reported by: c.herbig@… Owned by: rmstonecipher@…
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: jeremyhu (Jeremy Huddleston Sequoia), dbevans (David B. Evans)
Port: gstreamer1-gst-plugins-base

Description

The default +video variant is incompatible with the +quartz variant because +video still pulls in x11 deps (which may not be necessary...)

$ sudo port -y install webkit-gtk3
--->  Computing dependencies for webkit-gtk3
--->  Dependencies to be installed: autoconf help2man p5.12-locale-gettext automake gstreamer1-gst-plugins-base gnome-vfs gconf gtk-doc docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 xmlcatmgr docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 docbook-xsl gnome-doc-utils iso-codes pkgconfig py27-libxml2 rarian getopt orbit2 libidl policykit gnome-mime-data gstreamer1 gzip libtheora libvorbis libogg orc xorg-libice xorg-xproto xorg-xtrans xorg-libsm
For p5.12-locale-gettext: skipping org.macports.main (dry run)
For help2man: skipping org.macports.main (dry run)
For autoconf: skipping org.macports.main (dry run)
For automake: skipping org.macports.main (dry run)
For xmlcatmgr: skipping org.macports.main (dry run)
For docbook-xml-4.2: skipping org.macports.main (dry run)
For docbook-xml-4.1.2: skipping org.macports.main (dry run)
For docbook-xml-4.3: skipping org.macports.main (dry run)
For docbook-xml-4.4: skipping org.macports.main (dry run)
For docbook-xml-4.5: skipping org.macports.main (dry run)
For docbook-xml-5.0: skipping org.macports.main (dry run)
For docbook-xml: skipping org.macports.main (dry run)
For docbook-xsl: skipping org.macports.main (dry run)
For iso-codes: skipping org.macports.main (dry run)
For pkgconfig: skipping org.macports.main (dry run)
For py27-libxml2: skipping org.macports.main (dry run)
For getopt: skipping org.macports.main (dry run)
For rarian: skipping org.macports.main (dry run)
For gnome-doc-utils: skipping org.macports.main (dry run)
For gtk-doc: skipping org.macports.main (dry run)
For libidl: skipping org.macports.main (dry run)
For orbit2: skipping org.macports.main (dry run)
For policykit: skipping org.macports.main (dry run)
For gconf: skipping org.macports.main (dry run)
For gnome-mime-data: skipping org.macports.main (dry run)
For gnome-vfs: skipping org.macports.main (dry run)
For gzip: skipping org.macports.main (dry run)
For gstreamer1: skipping org.macports.main (dry run)
For libogg: skipping org.macports.main (dry run)
For libvorbis: skipping org.macports.main (dry run)
For libtheora: skipping org.macports.main (dry run)
For orc: skipping org.macports.main (dry run)
For xorg-xproto: skipping org.macports.main (dry run)
For xorg-xtrans: skipping org.macports.main (dry run)
For xorg-libice: skipping org.macports.main (dry run)
For xorg-libsm: skipping org.macports.main (dry run)
For gstreamer1-gst-plugins-base: skipping org.macports.main (dry run)
For webkit-gtk3: skipping org.macports.main (dry run)

So either the +video dependencies need to be reassessed, or +quartz should disable +video.

Change History (13)

comment:1 Changed 7 years ago by c.herbig@…

I had a chance to take a better look at this today. It seems the problem is that somehow +no_x11 is not getting passed down to gstreamer1-gst-plugins-base, just by using port rdeps webkit-gtk +quartz +video +no_x11, or port rdeps gstreamer1-gst-plugins-base +no_x11 directly. It's also an issue that gstreamer1-gst-plugins-base does not use the new ±variant system.

comment:2 Changed 7 years ago by c.herbig@…

It does this even from a clean install for me.

comment:3 Changed 7 years ago by c.herbig@…

If it is not something easily solved, then perhaps the best solution is to append into the +quartz section something to remove the default +video variant.

comment:4 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: invalid
Status: newclosed

This is behaving as designed.

comment:5 in reply to:  4 ; Changed 7 years ago by c.herbig@…

Replying to jeremyhu@…:

This is behaving as designed.

You were not able to duplicate it? I have recently noticed that another port I was trying had a dependency that did something similar, so I'm now wondering if something on my system is to blame.

comment:6 in reply to:  5 ; Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Replying to c.herbig@…:

Replying to jeremyhu@…:

This is behaving as designed.

You were not able to duplicate it?

No, I'm saying the behavior you are describing is intentional and correct. +quartz does not imply -x11 or +no_x11

I have recently noticed that another port I was trying had a dependency that did something similar, so I'm now wondering if something on my system is to blame.

comment:7 in reply to:  6 Changed 7 years ago by c.herbig@…

Replying to jeremyhu@…:

No, I'm saying the behavior you are describing is intentional and correct. +quartz does not imply -x11 or +no_x11

This is most strange, because my variants.conf specifies the following:

-x11
+no_x11
+quartz
+qt4_mac

+gtk3
-gtk2

yet it still pull in the X11 stuff. As I mentioned this is not the first incident of this type involving what variants.conf specifies vs what is specified from the terminal. The only thing that I can guess is that in doing some debugging, I used to switch between variants often.

comment:8 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Port: gstreamer1-gst-plugins-base added; webkit-gtk removed
Resolution: invalid
Status: closedreopened
Summary: Webkit-gtk @2.0.4_2 +quartz +video still pulls in x11 depsgstreamer1-gst-plugins-base +no_x11 still pulls in x11 deps

comment:9 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Owner: changed from macports-tickets@… to rmstonecipher@…
Status: reopenednew

comment:10 Changed 7 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Just because you have the +no_x11 variant set, that does not mean that you'll not have any X11 ports because some ports (eg: xorg) rely on them explicitly.

In this case, gstreamer1-gst-plugins-base does even though it has a +no_x11 variant.

That should be changed to a proper -x11 variant instead and adjust dependencies.

comment:11 Changed 7 years ago by dbevans (David B. Evans)

Fix committed in r113658. X11 deps are not used when building +no_x11.

comment:12 Changed 7 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

comment:13 Changed 7 years ago by dbevans (David B. Evans)

Similar fix for gstreamer010-gst-plugins-base committed in r113664.

Note: See TracTickets for help on using tickets.