Opened 8 years ago

Closed 8 years ago

#40314 closed enhancement (fixed)

libgda5 change dep gtksourceview2 to gtksourceview3, or provide variant for such

Reported by: c.herbig@… Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: dbevans (David B. Evans), cooljeanius (Eric Gallager)
Port: libgda5

Description

Is it acceptable to change the depends_lib port:gtksourceview2 to gtksourceview3? Currently, even trying to build libgda5 in a quartz environment will fail if any other port using gtk-osx-application is used, due to gtksourceview2 +quartz needing ige-mac-integration.

Additionally, I would like the configure.args section to explicitly state --with-ui, so that Gnumeric can be configured to detect gda support.

If it is not appropriate to change the default gtksourceview2 to 3, then can a variant, +gtk3 or such be made to make this change?

Change History (6)

comment:1 Changed 8 years ago by c.herbig@…

P.S. I think the gtk2 -> 3 also needs that goocanvas be updated to goocanvas2.

comment:2 Changed 8 years ago by c.herbig@…

Finally, the gnome-settings-daemon and yelp ports are not currently +quartz compatible.

comment:3 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:4 Changed 8 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to jwa@…
Version: 2.2.0

comment:5 Changed 8 years ago by c.herbig@…

I think I've figured out what I need:

port:gtksourceview3 \
port:goocanvas2

--with-ui
--enable-gda-gi
--enable-gdaui-gi

and a way to turn off for quartz

port:yelp
port:gnome-settings-daemon

comment:6 Changed 8 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Dependencies for libgda5 were updated in r111791 including the use of gtksourceview3, goocanvas2.

Turning off yelp and gnome-settings-daemon breaks functionality in the port.

Yelp is required for the Help menu to work and gnome-settings-daemon is necessary to allow theming to work properly among other things. A better approach would be figuring out how to fix these deficiencies in a quartz build. Nonetheless, you can remove these dependencies in a +quartz variant for your own purposes if you like.

The problem is that full session support for GNOME really depends on X11 at this point in time. The best you can do for +quartz for now is to port individual GNOME apps without session support. Depending on the app (and the interests of the upstream developers) this approach, as you have seen, may or may not be successful without significant upstream changes. Non X11 upstream development is more focused on Wayland right now.

My main focus at this point is to keep up with the rapidly changing upstream GNOME releases with +quartz as a background activity so any input you can give on how to make individual apps work with +quartz without breaking the full X11 capability is welcome and probably should be directed more at the upstream developers so that they can see there is a demand for it.

Thanks for your interest in this area.

Note: See TracTickets for help on using tickets.