Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#40416 closed defect (invalid)

apple-gcc42 @5666.3_12 fails build under PPC Tiger

Reported by: ultrajoe@… Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: ryandesign (Ryan Schmidt), cooljeanius (Eric Gallager), josephaw@…
Port: apple-gcc42

Description

While apple-gcc42 @5666.3_11 (from memory here) built find under Tiger, the current version fails to build properly, at least when built with the default compiler (XCode's apple-gcc-4.0). Since I built the previous update using itself (or the previous version of itself), I am attempting to rebuild using configure.compiler=apple-gcc-4.2.

Attachments (1)

main.log (2.2 MB) - added by ultrajoe@… 8 years ago.
Build log

Change History (19)

Changed 8 years ago by ultrajoe@…

Attachment: main.log added

Build log

comment:1 Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Owner: changed from macports-tickets@… to jeremyhu@…

The current version is actually @5666.3_13; please test whether that builds with the default gcc-4.0 compiler. (I'll do so as well.)

comment:2 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:3 Changed 8 years ago by ultrajoe@…

My apologies. The version should be 5666.3_13. I accidentally copied the output of port echo outdated, which shows the old version.

comment:4 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

The only difference between 12 and 13 is a patch for the +gpl3 variant =/

comment:5 Changed 8 years ago by ultrajoe@…

Strange.

For the record, though, it compiled under apple-gcc42 @5666.3_12. It's possible that _12 had the issue, as I had to compile other outdated ports with it. Since it takes about 4-5 hours just to get to that point, I'm a bit hesitant to retry it.

comment:6 Changed 8 years ago by ryandesign (Ryan Schmidt)

It built fine for me on Tiger PPC with the default gcc-4.0 compiler.

comment:7 Changed 8 years ago by josephaw@…

Cc: josephaw@… added

Cc Me!

comment:8 Changed 8 years ago by josephaw@…

Cc: josephaw@… removed

Cc Me!

comment:9 Changed 8 years ago by josephaw@…

Cc: josephaw@… added

Cc Me!

comment:10 Changed 8 years ago by josephaw@…

Any fixes yet. Failing with Tiger 5666.3_13 here. Thanks

comment:11 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Seeing as how this issue is occurring on Tiger/ppc, and Ryan isn't able to reproduce it, if there is going to be a fix, it is going to require more information from you. Try to figure out why it builds for Ryan and not you.

comment:12 in reply to:  11 ; Changed 8 years ago by ultrajoe@…

Replying to jeremyhu@…:

Seeing as how this issue is occurring on Tiger/ppc, and Ryan isn't able to reproduce it, if there is going to be a fix, it is going to require more information from you. Try to figure out why it builds for Ryan and not you.

It would help if someone could look at the log file and determine where the error is. I only saw an Error 139 returned, which means nothing to me.

I did try rebuilding @5666.3_12 using 4.0, but it finished without doing anything. I really didn't want to have to clean --all but it looks like I'll have to do so to get anywhere. Nonetheless, without the above log analysis, I don't know what other information to pass along!

Last edited 8 years ago by ultrajoe@… (previous) (diff)

comment:13 in reply to:  12 Changed 8 years ago by ryandesign (Ryan Schmidt)

Replying to ultrajoe@…:

It would help if someone could look at the log file and determine where the error is. I only saw an Error 139 returned, which means nothing to me.

I did try rebuilding @5666.3_12 using 4.0, but it finished without doing anything. I really didn't want to have to clean --all but it looks like I'll have to do so to get anywhere.

Certainly if the build failed with one compiler, and you want to retry with a different compiler, you should clean the port first. Cleaning --all, however, is not necessary. That would remove the distfiles, and there's nothing wrong with them. A normal clean, without --all, is fine.

Nonetheless, without the above log analysis, I don't know what other information to pass along!

I can try comparing the attached logfile with the one my system generated and see if any interesting differences show up.

comment:14 Changed 8 years ago by josephaw@…

I'll try to get some log output tomorrow sometime.

comment:15 Changed 8 years ago by josephaw@…

Here's the command line running as root and the log file.
(G4 1x933Mhz [PowerMac3,5][CPU PowerPC G4 (2.1)], 1.5GB ram, 10.4.11)

port clean apple-gcc42
--->  Cleaning apple-gcc42
port outdated
The following installed ports are outdated:
apple-gcc42                    5666.3_11 < 5666.3_13   
port upgrade outdated
--->  Computing dependencies for apple-gcc42
--->  Fetching distfiles for apple-gcc42
Error: Please install this port without the bootstrap variant.
Error: org.macports.fetch for port apple-gcc42 returned: Please install this port without the bootstrap variant.
Please see the log file for port apple-gcc42 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_apple-gcc42/apple-gcc42/main.log
Error: Unable to upgrade port: 1
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
version:1
:msg:main --->  Computing dependencies for apple-gcc42:info:main .:debug:main apple-gcc42 has no conflicts
:debug:main Searching for dependency: gcc_select
:debug:main Found Dependency: receipt exists for gcc_select
:msg:main 
:debug:main Executing org.macports.main (apple-gcc42)
:debug:main changing euid/egid - current euid: 0 - current egid: 0
:debug:main egid changed to: 500
:debug:main euid changed to: 502
:debug:main Skipping completed org.macports.archivefetch (apple-gcc42)
:debug:main Privilege de-escalation not attempted as not running as root.
:debug:fetch fetch phase started at Wed Sep 18 09:19:23 EDT 2013
:notice:fetch --->  Fetching distfiles for apple-gcc42
:debug:fetch Executing proc-pre-org.macports.fetch-fetch-0
:error:fetch Please install this port without the bootstrap variant.
:error:fetch org.macports.fetch for port apple-gcc42 returned: Please install this port without the bootstrap variant.
:debug:fetch Error code: NONE
:debug:fetch Backtrace: Please install this port without the bootstrap variant.
    while executing
"$pre $targetname"
:info:fetch Warning: targets not executed for apple-gcc42: org.macports.install org.macports.fetch org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot
:notice:fetch Please see the log file for port apple-gcc42 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_apple-gcc42/apple-gcc42/main.log
Last edited 8 years ago by ryandesign (Ryan Schmidt) (previous) (diff)

comment:16 Changed 8 years ago by josephaw@…

Now glib2 is failing to compile because it wants to compile apple-gcc42 first

comment:17 Changed 8 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Resolution: invalid
Status: newclosed

The instructions are right there in what you copy/pasted

Please install this port without the bootstrap variant.

Do this:

sudo port -v -s install cctools
sudo port -v -s install ld64
sudo port -v -f uninstall apple-gcc42
sudo port -v -s install apple-gcc42 -bootstrap

comment:18 Changed 8 years ago by josephaw@…

I already had xcode installed so I skipped the first two lines. I tried to remove the old apple-gcc42 but it said it was in use, so I just reinstalled it on top of the older version and it worked just fine, the problem was resolved and I was able to update glib2 as well. Thank you.

Note: See TracTickets for help on using tickets.