Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#40421 closed defect (invalid)

lua @5.2.2 Lua 5.1 should not be auto-upgraded to 5.2

Reported by: agladysh@… Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 2.2.0
Keywords: Cc: cooljeanius (Eric Gallager), anddam (Andrea D'Amore), hadrielk@…, alexeiz@…, mojca (Mojca Miklavec)
Port: lua

Description

Lua 5.2 is a different version of Lua language, not (fully) compatible with 5.1. Lua 5.2 is not widely supported (yet) by existing Lua modules.

It should be possible to user to have Both versions of Lua, 5.1 and 5.2 installed on the same machine.

Auto-upgrade from 5.1 to 5.2 has a good chance of breaking things up — which happened on my box. Please disable this.

Change History (11)

comment:1 Changed 8 years ago by neverpanic (Clemens Lang)

Owner: changed from macports-tickets@… to vince@…

Assgning to vince, who committed the lua 5.2 update.

comment:2 Changed 8 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:3 Changed 8 years ago by agladysh@…

Cc: agladysh@… added

Cc Me!

comment:4 Changed 8 years ago by agladysh@…

See also #40423

comment:5 Changed 8 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… added; agladysh@… removed

Can we make 'lua51' and 'lua52' coexist?

comment:6 Changed 8 years ago by hadrielk@…

Cc: hadrielk@… added

Cc Me!

comment:7 Changed 8 years ago by hadrielk@…

Can we at least have a macport for Lua 5.1, separately? Right now there's lua@5.2.1 and lua50@5.0.3, so a lua51@5.1.5 would be great.

comment:8 in reply to:  7 Changed 8 years ago by hadrielk@…

Replying to hadrielk@…:

Can we at least have a macport for Lua 5.1, separately? Right now there's lua@5.2.1 and lua50@5.0.3, so a lua51@5.1.5 would be great.

I submitted ticket #42901 to track that as an enhancement request. Perhaps if that's done we can close this ticket #40421 as well as #40423?

comment:9 Changed 8 years ago by alexeiz@…

Cc: alexeiz@… added

Cc Me!

comment:10 Changed 8 years ago by mojca (Mojca Miklavec)

Cc: mojca@… added

Cc Me!

comment:11 Changed 8 years ago by anddam (Andrea D'Amore)

Resolution: invalid
Status: newclosed

There's a new lua51 port, check ticket:42901#comment:7 , howewer the lua-* ports will still be depending on lua port and therefore on the latest stable.

If you want to keep your default lua version to 5.1 you have to pinpoint 5.1 by creating your local repository as explained here.

I'm closing this as invalid since it's not clear what the problem is, reopen the ticket if you can provide more detailed info.

add:

We cannot "disable auto-upgrade" because of how MacPorts works.

What could be done instead is provide a set of versioned lua-* modules so that they could all coexist with different lua versions. This would require a certain amount of work and the port are mostly non-maintained at the moment. So patches are welcome, as always.

Last edited 8 years ago by anddam (Andrea D'Amore) (previous) (diff)
Note: See TracTickets for help on using tickets.